aboutsummaryrefslogtreecommitdiff
path: root/math/oleo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-08 23:40:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-08 23:40:56 +0000
commit9bbd56d5ed8dc61c966b38fb5112a2fd7eb20f36 (patch)
tree73799368e290cf8ec1800d402bbcc7e444b79b1d /math/oleo
parent597b0212d9d883820b78b60723d4506c510ed6a2 (diff)
downloadports-9bbd56d5ed8dc61c966b38fb5112a2fd7eb20f36.tar.gz
ports-9bbd56d5ed8dc61c966b38fb5112a2fd7eb20f36.zip
- Fix build with gcc 4.2
- Pass maintainership to submitter PR: 120415 Submitted by: "Pietro Cerutti" <gahr@gahr.ch>
Notes
Notes: svn path=/head/; revision=206919
Diffstat (limited to 'math/oleo')
-rw-r--r--math/oleo/Makefile10
-rw-r--r--math/oleo/files/patch-src_basic.h12
-rw-r--r--math/oleo/files/patch-src_io-term.c25
-rw-r--r--math/oleo/files/patch-src_io-term.h10
4 files changed, 49 insertions, 8 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 5f636a8b92ca..512c0bc5c774 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= The GNU spreadsheet for X11 and terminals
USE_PERL5_BUILD= yes
@@ -28,12 +28,6 @@ PORTDOCS= AUTHORS FAQ
OPTIONS= MOTIF "Motif support" off \
NLS "NLS support" on
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
.if defined(WITH_MOTIF)
LIB_DEPENDS+= plot:${PORTSDIR}/graphics/plotutils \
Xbae:${PORTSDIR}/x11-toolkits/xbae \
@@ -72,4 +66,4 @@ pre-build:
&& iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/oleo/files/patch-src_basic.h b/math/oleo/files/patch-src_basic.h
new file mode 100644
index 000000000000..6cd7d73f0a2c
--- /dev/null
+++ b/math/oleo/files/patch-src_basic.h
@@ -0,0 +1,12 @@
+--- src/basic.h.orig 2008-02-08 16:40:42.000000000 +0100
++++ src/basic.h 2008-02-08 16:40:48.000000000 +0100
+@@ -36,9 +36,6 @@
+
+ extern const int colmagic[9];
+ extern const int rowmagic[9];
+-extern char * motion_name[9];
+-extern enum motion_magic complementary_motion[9];
+-extern enum motion_magic opposite_motion[9];
+
+ extern int run_load_hooks;
+
diff --git a/math/oleo/files/patch-src_io-term.c b/math/oleo/files/patch-src_io-term.c
new file mode 100644
index 000000000000..16f7beff3e03
--- /dev/null
+++ b/math/oleo/files/patch-src_io-term.c
@@ -0,0 +1,25 @@
+--- src/io-term.c.orig 2008-02-08 16:43:28.000000000 +0100
++++ src/io-term.c 2008-02-08 16:45:06.000000000 +0100
+@@ -220,6 +220,7 @@
+ {
+ int set_opt = 1;
+ int i, l;
++ int *tmp;
+ char *p;
+
+ while (*ptr == ' ')
+@@ -234,9 +235,11 @@
+
+ if (Preferences[i].copynext) {
+ ptr += strlen(Preferences[i].name) + 1;
+- ((char *)Preferences[i].var) = strdup(ptr);
+- } else if (Preferences[i].var)
+- *((int *)Preferences[i].var) = Preferences[i].value;
++ Preferences[i].var = strdup(ptr);
++ } else if (Preferences[i].var) {
++ tmp = Preferences[i].var;
++ *tmp = Preferences[i].value;
++ }
+
+ if (Preferences[i].cont == 0)
+ return 1;
diff --git a/math/oleo/files/patch-src_io-term.h b/math/oleo/files/patch-src_io-term.h
new file mode 100644
index 000000000000..df73b04bdf98
--- /dev/null
+++ b/math/oleo/files/patch-src_io-term.h
@@ -0,0 +1,10 @@
+--- src/io-term.h.orig 2008-02-08 16:38:59.000000000 +0100
++++ src/io-term.h 2008-02-08 16:38:48.000000000 +0100
+@@ -21,6 +21,7 @@
+ */
+
+ #include <setjmp.h>
++#include "funcs.h"
+ #include "global.h"
+
+ extern int using_x;