aboutsummaryrefslogtreecommitdiff
path: root/math/oleo
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-07 21:27:03 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-07 21:27:03 +0000
commitcab21309ccc8edbccb45ec2af74c2d36399e474f (patch)
tree06a9dfe86feedbe65ae57893ebb51e31998faf7b /math/oleo
parent595ad0e9128c10ace690101f696a7614550fb63f (diff)
downloadports-cab21309ccc8edbccb45ec2af74c2d36399e474f.tar.gz
ports-cab21309ccc8edbccb45ec2af74c2d36399e474f.zip
- unbreak;
- do some cleaning.
Notes
Notes: svn path=/head/; revision=111034
Diffstat (limited to 'math/oleo')
-rw-r--r--math/oleo/Makefile23
-rw-r--r--math/oleo/files/patch-ad2
-rw-r--r--math/oleo/files/patch-ai13
-rw-r--r--math/oleo/files/patch-src::sysdef.h12
-rw-r--r--math/oleo/pkg-plist26
5 files changed, 52 insertions, 24 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 6c333da5dbcd..0e5a34e85b78 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -24,6 +24,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
+INFO= oleo
+PORTDOCS= AUTHORS FAQ
+
.if defined(WITH_MOTIF)
LIB_DEPENDS+= plot:${PORTSDIR}/graphics/plotutils \
Xbae:${PORTSDIR}/x11-toolkits/xbae \
@@ -35,10 +38,11 @@ USE_XLIB= yes
CONFIGURE_ARGS+= --without-motif
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502000
-BROKEN= "Does not compile"
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB= NLS="@comment "
+.else
+PLIST_SUB= NLS=""
.endif
pre-everything::
@@ -52,6 +56,15 @@ pre-everything::
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+.for pof in en fr nl
+ @${REINPLACE_CMD} -e "s|CHARSET|ISO-8859-1|;s|ENCODING|8bit|" \
+ ${WRKSRC}/po/${pof}.po
+.endfor
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|am: install-docDATA|am:|" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|install-info-am install-htmlDATA|install-info-am|" \
+ ${WRKSRC}/doc/Makefile.in
+.endif
pre-build:
.for file in src/io-term.c
@@ -59,4 +72,4 @@ pre-build:
&& iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/oleo/files/patch-ad b/math/oleo/files/patch-ad
index ea31af6138ca..fe123bbbd2ad 100644
--- a/math/oleo/files/patch-ad
+++ b/math/oleo/files/patch-ad
@@ -13,7 +13,7 @@
EXTRA_DIST = oleobug.in FAQ oleo.spec.in oleo.spec
-docdir = $(prefix)/Oleo
-+docdir = $(datadir)/doc/Oleo
++docdir = $(datadir)/doc/oleo
doc_DATA = AUTHORS FAQ
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/math/oleo/files/patch-ai b/math/oleo/files/patch-ai
index 4643659df60c..a5f5122a722b 100644
--- a/math/oleo/files/patch-ai
+++ b/math/oleo/files/patch-ai
@@ -1,5 +1,5 @@
---- doc/Makefile.in.orig Sat Jul 22 18:51:35 2000
-+++ doc/Makefile.in Fri Jul 28 03:02:45 2000
+--- doc/Makefile.in.orig Sat Mar 10 15:32:46 2001
++++ doc/Makefile.in Mon Jun 7 21:52:58 2004
@@ -87,7 +87,7 @@
LIBOBJS = @LIBOBJS@
LN_S = @LN_S@
@@ -9,3 +9,12 @@
MKINSTALLDIRS = @MKINSTALLDIRS@
MOTIF_CFLAGS = @MOTIF_CFLAGS@
MOTIF_LIBS = @MOTIF_LIBS@
+@@ -125,7 +125,7 @@
+ EXTRA_DIST = $(TEXIS) oleo_web.html texi2html oleo1.png
+ noinst_DATA = oleo_web.html $(TEXIS)
+
+-@HavePerl_TRUE@htmldir = $(prefix)/share/oleo
++@HavePerl_TRUE@htmldir = $(prefix)/share/doc/oleo
+ @HavePerl_TRUE@html_DATA = oleo.html
+
+ DISTCLEANFILES = $(html_DATA)
diff --git a/math/oleo/files/patch-src::sysdef.h b/math/oleo/files/patch-src::sysdef.h
new file mode 100644
index 000000000000..ffbad7e4255d
--- /dev/null
+++ b/math/oleo/files/patch-src::sysdef.h
@@ -0,0 +1,12 @@
+--- src/sysdef.h.orig Sun Feb 4 16:54:21 2001
++++ src/sysdef.h Sun Jun 6 23:08:43 2004
+@@ -119,7 +119,9 @@
+
+ #endif /* !defined(__STDC__) */
+
++#ifndef __FreeBSD__
+ extern char *getenv ();
++#endif
+
+ #ifndef RETSIGTYPE
+ #define RETSIGTYPE void
diff --git a/math/oleo/pkg-plist b/math/oleo/pkg-plist
index 96f6bc7da906..2135037d08ac 100644
--- a/math/oleo/pkg-plist
+++ b/math/oleo/pkg-plist
@@ -1,17 +1,11 @@
bin/oleo
-@unexec install-info --delete %D/info/oleo.info %D/info/dir
-info/oleo.info
-@exec install-info %D/info/oleo.info %D/info/dir
-share/doc/Oleo/AUTHORS
-share/doc/Oleo/FAQ
-share/locale/en/LC_MESSAGES/oleo.mo
-share/locale/fr/LC_MESSAGES/oleo.mo
-share/locale/nl/LC_MESSAGES/oleo.mo
-share/oleo/Oleo
-share/oleo/fr/Oleo
-share/oleo/nl/Oleo
-share/oleo/oleo.html
-@dirrm share/oleo/nl
-@dirrm share/oleo/fr
-@dirrm share/oleo
-@dirrm share/doc/Oleo
+%%NLS%%share/locale/en/LC_MESSAGES/oleo.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/oleo.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/oleo.mo
+%%DATADIR%%/Oleo
+%%DATADIR%%/fr/Oleo
+%%DATADIR%%/nl/Oleo
+%%PORTDOCS%%%%DOCSDIR%%/oleo.html
+@dirrm %%DATADIR%%/nl
+@dirrm %%DATADIR%%/fr
+@dirrm %%DATADIR%%