aboutsummaryrefslogtreecommitdiff
path: root/math/onednn
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-08 12:08:09 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-08 12:08:09 +0000
commit55311fcc1420021114dd1397e5bf91d3f423ed91 (patch)
tree81451c672f1fe4a433e6fa1f90104ca1c08d866b /math/onednn
parent42a72a581b866d5e8fc28843c2686cf664cca136 (diff)
math/onednn: disable on 32-bit architectures
Attempt to build on powerpc fails: CMake Error at CMakeLists.txt:87 (message): oneDNN supports 64 bit platforms only This also makes BROKEN_i386 unnecessary.
Diffstat (limited to 'math/onednn')
-rw-r--r--math/onednn/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/onednn/Makefile b/math/onednn/Makefile
index 685ba8be255c..75e6c22d40fd 100644
--- a/math/onednn/Makefile
+++ b/math/onednn/Makefile
@@ -9,8 +9,8 @@ COMMENT= Intel(R) Math Kernel Library for Deep Neural Networks
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+NOT_FOR_ARCHS= armv6 armv7 i386 mips powerpc powerpcspe
BROKEN_aarch64= error: sys/prctl.h file not found
-BROKEN_i386= error: shift count >= width of type (and other errors), see https://github.com/intel/mkl-dnn/issues/315
TEST_DEPENDS= bash:shells/bash \
libsysinfo>0:devel/libsysinfo