aboutsummaryrefslogtreecommitdiff
path: root/math/openblas
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-03-15 16:55:25 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-03-15 16:55:25 +0000
commit4c1e724aa1664b885b91ad325bff21158fa83918 (patch)
treec560df46369d7def43955421cfea212d1c601799 /math/openblas
parent9c71436bda7d24dfe34bdebe032bab63e1b11a31 (diff)
downloadports-4c1e724aa1664b885b91ad325bff21158fa83918.tar.gz
ports-4c1e724aa1664b885b91ad325bff21158fa83918.zip
Do not force GCC when OPENMP is selected.
PR: 254284 Submitted by: /me Approved by: phd_kimberlite (maintainer)
Notes
Notes: svn path=/head/; revision=568472
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index c235ac46aa94..d3630c1b5bfa 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -4,6 +4,7 @@
PORTNAME= openblas
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.13
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math
MASTER_SITES= NL/lapack/timing/:lapack_tmg
@@ -17,7 +18,7 @@ COMMENT= Optimized BLAS library based on GotoBLAS2
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= fortran gmake perl5 pkgconfig
+USES= compiler:c11 fortran gmake perl5 pkgconfig
CONFLICTS_INSTALL= cblas lapacke
@@ -88,20 +89,8 @@ MAXTHREADS?= 64
MANUAL_PACKAGE_BUILD= Optimizes for the build machine.
.endif
-.if ${PORT_OPTIONS:MOPENMP}
-USES+= compiler:openmp
-.else
-USES+= compiler:c11
-.endif
-
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MOPENMP}
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-USE_GCC= yes
-.endif
-.endif
-
post-extract:
cd ${DISTDIR}/${DIST_SUBDIR} ; \
${CP} ${LARGE_FILE} ${TIMING_FILE} ${WRKSRC}