aboutsummaryrefslogtreecommitdiff
path: root/math/openblas
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2017-01-02 03:56:15 +0000
committerCy Schubert <cy@FreeBSD.org>2017-01-02 03:56:15 +0000
commit51b47d9105e8f1361cb3c2c9c315bd2280b09b2e (patch)
tree617b02e420f3de9073f57ef8832bd5730cdff19e /math/openblas
parenta054f8bf1f2b99b4438d1ac1ee4f6541e5725018 (diff)
downloadports-51b47d9105e8f1361cb3c2c9c315bd2280b09b2e.tar.gz
ports-51b47d9105e8f1361cb3c2c9c315bd2280b09b2e.zip
Update 0.2.18 --> 0.2.19
PR: 215699 Submitted by: cy Approved by: maintainer (phd_kimberlite@yahoo.co.jp)
Notes
Notes: svn path=/head/; revision=430307
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile3
-rw-r--r--math/openblas/distinfo7
-rw-r--r--math/openblas/files/patch-interface__ztrmv.c8
3 files changed, 10 insertions, 8 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index f1684c3deca8..09669cf74942 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openblas
-PORTVERSION= 0.2.18
-PORTREVISION= 3
+PORTVERSION= 0.2.19
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= math
diff --git a/math/openblas/distinfo b/math/openblas/distinfo
index 63378e966688..c771f550b6af 100644
--- a/math/openblas/distinfo
+++ b/math/openblas/distinfo
@@ -1,6 +1,9 @@
-SHA256 (openblas/xianyi-OpenBLAS-v0.2.18_GH0.tar.gz) = 7d9f8d4ea4a65ab68088f3bb557f03a7ac9cb5036ef2ba30546c3a28774a4112
-SIZE (openblas/xianyi-OpenBLAS-v0.2.18_GH0.tar.gz) = 10689322
+TIMESTAMP = 1483295026
+SHA256 (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 9c40b5e4970f27c5f6911cb0a28aa26b6c83f17418b69f8e5a116bb983ca8557
+SIZE (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 10834034
SHA256 (openblas/large.tgz) = f328d88b7fa97722f271d7d0cfea1c220e0f8e5ed5ff01d8ef1eb51d6f4243a1
SIZE (openblas/large.tgz) = 2595
SHA256 (openblas/timing.tgz) = 999c65f8ea8bd4eac7f1c7f3463d4946917afd20a997807300fe35d70122f3af
SIZE (openblas/timing.tgz) = 1059485
+SHA256 (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 9c40b5e4970f27c5f6911cb0a28aa26b6c83f17418b69f8e5a116bb983ca8557
+SIZE (openblas/xianyi-OpenBLAS-v0.2.19_GH0.tar.gz) = 10834034
diff --git a/math/openblas/files/patch-interface__ztrmv.c b/math/openblas/files/patch-interface__ztrmv.c
index 8261277d89e9..75c92100b3e2 100644
--- a/math/openblas/files/patch-interface__ztrmv.c
+++ b/math/openblas/files/patch-interface__ztrmv.c
@@ -1,11 +1,11 @@
---- interface/ztrmv.c.orig 2016-04-12 12:29:19.000000000 -0700
-+++ interface/ztrmv.c 2016-06-08 16:44:31.800058000 -0700
+--- interface/ztrmv.c.orig 2016-08-31 20:58:42.000000000 -0700
++++ interface/ztrmv.c 2017-01-01 10:26:22.759442000 -0800
@@ -242,7 +242,7 @@
else
#endif
{
- buffer_size = ((n - 1) / DTB_ENTRIES) * 2 * DTB_ENTRIES + 32 / sizeof(FLOAT);
+ buffer_size = (((n - 1) / DTB_ENTRIES) * 2 * DTB_ENTRIES + 32 / sizeof(FLOAT)) + 8;
+ // It seems to be required for some K8 or Barcelona CPU
+ buffer_size += 8;
if(incx != 1)
- buffer_size += n * 2;
- }