aboutsummaryrefslogtreecommitdiff
path: root/math/openblas
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-02-25 18:19:50 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-02-25 18:19:50 +0000
commitd6a774a4d445216ba67052f64598056d182bd1f2 (patch)
treec3ce9095076846a38ec28a4b8e560ae76239828e /math/openblas
parentc48ecad3ef981da77d9f5b9d89663b656a1d8a28 (diff)
downloadports-d6a774a4d445216ba67052f64598056d182bd1f2.tar.gz
ports-d6a774a4d445216ba67052f64598056d182bd1f2.zip
math/openblas: Fix build on 12-CURRENT armv6.
The build still fails on 11 armv6, however MFC of r313873 will hopefully fix the build there as well. While here also add LICENSE_FILE and fix portlint warnings. PR: 217279 Submitted by: mikael.urankar@gmail.com Approved by: phd_kimberlite@yahoo.co.jp (maintainer), swills (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D9801
Notes
Notes: svn path=/head/; revision=434832
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile1
-rw-r--r--math/openblas/files/patch-common__arm.h24
-rw-r--r--math/openblas/files/patch-cpuid__arm.c12
-rw-r--r--math/openblas/files/patch-interface__ztrmv.c6
4 files changed, 40 insertions, 3 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 7aba2e92c24a..c7acab4a5431 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= phd_kimberlite@yahoo.co.jp
COMMENT= Optimized BLAS library based on GotoBLAS2
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= xianyi
diff --git a/math/openblas/files/patch-common__arm.h b/math/openblas/files/patch-common__arm.h
new file mode 100644
index 000000000000..079c7f7f9d23
--- /dev/null
+++ b/math/openblas/files/patch-common__arm.h
@@ -0,0 +1,24 @@
+--- common_arm.h.orig 2016-09-01 03:58:42 UTC
++++ common_arm.h
+@@ -93,6 +93,13 @@ static inline int blas_quickdivide(blasi
+
+ #endif
+
++/* Translate pre-UAL asm to UAL equivalents */
++#if defined(__clang__)
++#define fnmacs vmls.f32
++#define fnmacd vmls.f64
++#define fnmuls vnmul.f32
++#define fnmuld vnmul.f64
++#endif
+
+ #ifndef F_INTERFACE
+ #define REALNAME ASMNAME
+@@ -105,7 +112,6 @@ static inline int blas_quickdivide(blasi
+ #define PROLOGUE \
+ .arm ;\
+ .global REALNAME ;\
+- .func REALNAME ;\
+ REALNAME:
+
+ #define EPILOGUE
diff --git a/math/openblas/files/patch-cpuid__arm.c b/math/openblas/files/patch-cpuid__arm.c
new file mode 100644
index 000000000000..11bdbb26c5f2
--- /dev/null
+++ b/math/openblas/files/patch-cpuid__arm.c
@@ -0,0 +1,12 @@
+--- cpuid_arm.c.orig 2016-09-01 03:58:42 UTC
++++ cpuid_arm.c
+@@ -181,7 +181,8 @@ int detect(void)
+ }
+
+ }
+-
++#else
++ return CPU_ARMV6;
+ #endif
+
+ return CPU_UNKNOWN;
diff --git a/math/openblas/files/patch-interface__ztrmv.c b/math/openblas/files/patch-interface__ztrmv.c
index 75c92100b3e2..f11da94c6e1c 100644
--- a/math/openblas/files/patch-interface__ztrmv.c
+++ b/math/openblas/files/patch-interface__ztrmv.c
@@ -1,6 +1,6 @@
---- interface/ztrmv.c.orig 2016-08-31 20:58:42.000000000 -0700
-+++ interface/ztrmv.c 2017-01-01 10:26:22.759442000 -0800
-@@ -242,7 +242,7 @@
+--- interface/ztrmv.c.orig 2016-09-01 03:58:42 UTC
++++ interface/ztrmv.c
+@@ -242,7 +242,7 @@ void CNAME(enum CBLAS_ORDER order, enum
else
#endif
{