aboutsummaryrefslogtreecommitdiff
path: root/math/openblas
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-04 11:37:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-06-04 11:37:24 +0000
commite61a6d80b0ca971848fe3bc6d993f8a32d4e5b09 (patch)
tree6f8e88cb4ee69af01e4c2cb7befc045ecb492bbc /math/openblas
parent84571603ce466d163180ae994d9d559b3b685f9c (diff)
downloadports-e61a6d80b0ca971848fe3bc6d993f8a32d4e5b09.tar.gz
ports-e61a6d80b0ca971848fe3bc6d993f8a32d4e5b09.zip
math/openblas: fix build on powerpc
Merge upstream commit to fix build on powerpc. Use GCC from ports to build it. Since this is mostly about G3 and G4 machines that users have and OpenBLAS supports only G4 of those, target G4. Due to some (still unknown) regression on head, this builds on 12.1, but fails tests on head.
Notes
Notes: svn path=/head/; revision=537882
Diffstat (limited to 'math/openblas')
-rw-r--r--math/openblas/Makefile6
-rw-r--r--math/openblas/distinfo4
2 files changed, 9 insertions, 1 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index bb92591615fe..ba3727cbacbf 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -14,6 +14,7 @@ DIST_SUBDIR= openblas
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= ee2e758278b5d82b7242f505ea694f082ef65879.patch:-p1 # fixes the regression: https://github.com/xianyi/OpenBLAS/pull/2512
+PATCHFILES+= 3eda3d34c3d9bfabb29e1d8a69860932334a815d.patch:-p1 # fixes build on powerpc (PPCG4)
MAINTAINER= phd_kimberlite@yahoo.co.jp
COMMENT= Optimized BLAS library based on GotoBLAS2
@@ -70,6 +71,11 @@ TARGET_CPU_ARCH= PPC970
. endif
.endif
+.if ${ARCH} == powerpc
+USE_GCC= yes
+TARGET_CPU_ARCH= PPCG4
+.endif
+
MAXTHREADS?= 64
.if ! ${PORT_OPTIONS:MDYNAMIC_ARCH} && ( ${ARCH} == "amd64" || ${ARCH} == "i386" )
diff --git a/math/openblas/distinfo b/math/openblas/distinfo
index d449c1e19e94..e37bf2dc03f5 100644
--- a/math/openblas/distinfo
+++ b/math/openblas/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1588802954
+TIMESTAMP = 1591268760
SHA256 (openblas/large.tgz) = f328d88b7fa97722f271d7d0cfea1c220e0f8e5ed5ff01d8ef1eb51d6f4243a1
SIZE (openblas/large.tgz) = 2595
SHA256 (openblas/timing.tgz) = 999c65f8ea8bd4eac7f1c7f3463d4946917afd20a997807300fe35d70122f3af
@@ -7,3 +7,5 @@ SHA256 (openblas/xianyi-OpenBLAS-v0.3.9_GH0.tar.gz) = 17d4677264dfbc4433e9707622
SIZE (openblas/xianyi-OpenBLAS-v0.3.9_GH0.tar.gz) = 12184323
SHA256 (openblas/ee2e758278b5d82b7242f505ea694f082ef65879.patch) = 9210a94ae418b4ce6d9f7fab4e00dd3155451f5ef3769536a4d954a2149ca733
SIZE (openblas/ee2e758278b5d82b7242f505ea694f082ef65879.patch) = 2028
+SHA256 (openblas/3eda3d34c3d9bfabb29e1d8a69860932334a815d.patch) = 849b91e8422b87ad58687435a921e295dbdd74eec9597331d10b7438c39f246b
+SIZE (openblas/3eda3d34c3d9bfabb29e1d8a69860932334a815d.patch) = 2988