aboutsummaryrefslogtreecommitdiff
path: root/math/or-tools
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-03 21:30:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-03 21:30:52 +0000
commit50166d4b8536c6b0b3624a9627c5713a3b57a293 (patch)
treebfbe7477ff489ab52e70e06190b793f4e0d3bca6 /math/or-tools
parent74b7c06ba5a6824e6f6c17c01a8283bccc190fe9 (diff)
downloadports-50166d4b8536c6b0b3624a9627c5713a3b57a293.tar.gz
ports-50166d4b8536c6b0b3624a9627c5713a3b57a293.zip
math/or-tools: Update 8.1 -> 8.2
Notes
Notes: svn path=/head/; revision=567261
Diffstat (limited to 'math/or-tools')
-rw-r--r--math/or-tools/Makefile9
-rw-r--r--math/or-tools/distinfo6
-rw-r--r--math/or-tools/pkg-plist66
3 files changed, 11 insertions, 70 deletions
diff --git a/math/or-tools/Makefile b/math/or-tools/Makefile
index 2b4f3bc1ae05..c85f77c61d6c 100644
--- a/math/or-tools/Makefile
+++ b/math/or-tools/Makefile
@@ -2,8 +2,7 @@
PORTNAME= or-tools
DISTVERSIONPREFIX= v
-DISTVERSION= 8.1
-PORTREVISION= 1
+DISTVERSION= 8.2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -25,7 +24,8 @@ USE_GITHUB= yes
GH_ACCOUNT= google
USE_LDCONFIG= yes
-CMAKE_OFF= BUILD_DEPS INSTALL_BUILD_DEPS BUILD_PYTHON BUILD_EXAMPLES
+CMAKE_OFF= BUILD_PYTHON BUILD_DEPS INSTALL_BUILD_DEPS BUILD_EXAMPLES BUILD_SAMPLES
+CMAKE_ON= BUILD_CXX
CONFIGURE_ENV= UNIX_CBC_DIR=${LOCALBASE} UNIX_CLP_DIR=${LOCALBASE}
OPTIONS_DEFINE= SCIP
@@ -35,9 +35,6 @@ SCIP_DESC= Use the SCIP solver # SCIP package isn't built because of licensing
SCIP_CMAKE_BOOL= USE_SCIP
SCIP_LIB_DEPENDS= libscip.so:math/SCIP
-post-configure: # https://github.com/google/or-tools/issues/2109
- @${REINPLACE_CMD} -e 's|protobuf::protoc|protoc -I${LOCALBASE}/include| ; s|protobuf$$:$$:protoc||' ${BUILD_WRKSRC}/build.ninja
-
post-install:
@${FIND} ${STAGEDIR}${PREFIX} -type d -empty -delete
diff --git a/math/or-tools/distinfo b/math/or-tools/distinfo
index 62757409864e..7729f80565c2 100644
--- a/math/or-tools/distinfo
+++ b/math/or-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1607763769
-SHA256 (google-or-tools-v8.1_GH0.tar.gz) = beb9fe379977033151045d0815d26c628ad99d74d68b9f3b707578492723731e
-SIZE (google-or-tools-v8.1_GH0.tar.gz) = 232290953
+TIMESTAMP = 1614802562
+SHA256 (google-or-tools-v8.2_GH0.tar.gz) = cf40715fa5cfeee88e2c8f5583465182c8dedf60b4eb7c4a967b32ff61ac4302
+SIZE (google-or-tools-v8.2_GH0.tar.gz) = 236722388
diff --git a/math/or-tools/pkg-plist b/math/or-tools/pkg-plist
index 3832ede0b7ae..b4c4806dee67 100644
--- a/math/or-tools/pkg-plist
+++ b/math/or-tools/pkg-plist
@@ -1,63 +1,4 @@
-bin/assignment_mip
-bin/assignment_sat
-bin/basic_example
-bin/bin_packing_mip
-bin/binpacking_problem_sat
-bin/bool_or_sample_sat
-bin/channeling_sample_sat
-bin/cp_is_fun_sat
-bin/earliness_tardiness_cost_sample_sat
bin/fz
-bin/integer_programming_example
-bin/interval_sample_sat
-bin/knapsack
-bin/linear_programming_example
-bin/literal_sample_sat
-bin/minimal_jobshop_cp
-bin/mip_var_array
-bin/multiple_knapsack_mip
-bin/multiple_knapsack_sat
-bin/no_overlap_sample_sat
-bin/nurses_cp
-bin/optional_interval_sample_sat
-bin/rabbits_and_pheasants_cp
-bin/rabbits_and_pheasants_sat
-bin/ranking_sample_sat
-bin/reified_sample_sat
-bin/search_for_all_solutions_sample_sat
-bin/simple_cp_program
-bin/simple_knapsack_program
-bin/simple_lp_program
-bin/simple_ls_program
-bin/simple_max_flow_program
-bin/simple_min_cost_flow_program
-bin/simple_mip_program
-bin/simple_routing_program
-bin/simple_sat_program
-bin/solution_hinting_sample_sat
-bin/solve_and_print_intermediate_solutions_sample_sat
-bin/solve_with_time_limit_sample_sat
-bin/step_function_sample_sat
-bin/stop_after_n_solutions_sample_sat
-bin/tsp
-bin/tsp_circuit_board
-bin/tsp_cities
-bin/tsp_cities_routes
-bin/tsp_distance_matrix
-bin/vrp
-bin/vrp_capacity
-bin/vrp_drop_nodes
-bin/vrp_global_span
-bin/vrp_initial_routes
-bin/vrp_pickup_delivery
-bin/vrp_pickup_delivery_fifo
-bin/vrp_pickup_delivery_lifo
-bin/vrp_resources
-bin/vrp_routes
-bin/vrp_starts_ends
-bin/vrp_time_windows
-bin/vrp_with_time_limit
-bin/vrptw_store_solution_data
include/ortools/algorithms/dense_doubly_linked_list.h
include/ortools/algorithms/dynamic_partition.h
include/ortools/algorithms/dynamic_permutation.h
@@ -79,6 +20,7 @@ include/ortools/base/dynamic_library.h
include/ortools/base/encodingutils.h
include/ortools/base/file.h
include/ortools/base/filelineiter.h
+include/ortools/base/gzipstring.h
include/ortools/base/hash.h
include/ortools/base/int_type.h
include/ortools/base/integral_types.h
@@ -251,6 +193,7 @@ include/ortools/sat/cp_model_objective.h
include/ortools/sat/cp_model_postsolve.h
include/ortools/sat/cp_model_presolve.h
include/ortools/sat/cp_model_search.h
+include/ortools/sat/cp_model_service.pb.h
include/ortools/sat/cp_model_solver.h
include/ortools/sat/cp_model_symmetries.h
include/ortools/sat/cp_model_utils.h
@@ -294,6 +237,7 @@ include/ortools/sat/simplification.h
include/ortools/sat/subsolver.h
include/ortools/sat/swig_helper.h
include/ortools/sat/symmetry.h
+include/ortools/sat/symmetry_util.h
include/ortools/sat/synchronization.h
include/ortools/sat/table.h
include/ortools/sat/theta_tree.h
@@ -344,10 +288,10 @@ lib/cmake/ortools/ortoolsTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/ortools/ortoolsTargets.cmake
lib/libflatzinc.so
lib/libflatzinc.so.8
-lib/libflatzinc.so.8.1.9999
+lib/libflatzinc.so.8.2.9999
lib/libortools.so
lib/libortools.so.8
-lib/libortools.so.8.1.9999
+lib/libortools.so.8.2.9999
share/minizinc/ortools/fzn_all_different_int.mzn
share/minizinc/ortools/fzn_circuit.mzn
share/minizinc/ortools/fzn_cumulative.mzn