aboutsummaryrefslogtreecommitdiff
path: root/math/orpie
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-05-02 05:26:40 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-05-02 05:26:40 +0000
commit8c99ed5982716a3f399ccfd97312b79b3d691d4b (patch)
tree3011639bcd64afa0e9b4dea9964e5ffbc5889570 /math/orpie
parent89a897fcf325b079d0b7315882963db5c5452568 (diff)
downloadports-8c99ed5982716a3f399ccfd97312b79b3d691d4b.tar.gz
ports-8c99ed5982716a3f399ccfd97312b79b3d691d4b.zip
Update math/gsl to 2.3
This release introduces some new features and fixes several bugs: http://savannah.gnu.org/forum/forum.php?forum_id=8751 * update to 2.3 and take maintainership * update math/py-gsl to 2.2.0 for gsl2 support * update math/rubygem-rb-gsl to 2.1.0.2 for gsl2 support PR: 218952 Exp-run by: antoine Reviewed by: mat, rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D10522
Notes
Notes: svn path=/head/; revision=439928
Diffstat (limited to 'math/orpie')
-rw-r--r--math/orpie/Makefile2
-rw-r--r--math/orpie/files/patch-gsl_mlgsl__sf.c36
2 files changed, 37 insertions, 1 deletions
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 71f7b4201e2c..2bf30c499e86 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -3,7 +3,7 @@
PORTNAME= orpie
PORTVERSION= 1.5.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= math
MASTER_SITES= http://pessimization.com/software/orpie/
diff --git a/math/orpie/files/patch-gsl_mlgsl__sf.c b/math/orpie/files/patch-gsl_mlgsl__sf.c
new file mode 100644
index 000000000000..3f7dec98222a
--- /dev/null
+++ b/math/orpie/files/patch-gsl_mlgsl__sf.c
@@ -0,0 +1,36 @@
+Obtained from:
+https://sources.debian.net/src/orpie/1.5.2-1/debian/patches/gsl-fix/
+
+Description: fix some incompatibilities with libgsl 2.1
+Author: Uwe Steinmann <steinm@debian.org>
+Forwarded: not-needed
+
+--- gsl/mlgsl_sf.c.orig 2014-04-12 01:43:31 UTC
++++ gsl/mlgsl_sf.c
+@@ -258,7 +258,8 @@ SF2(ellint_Dcomp, Double_val, GSL_MODE_v
+ SF3(ellint_F, Double_val, Double_val, GSL_MODE_val)
+ SF3(ellint_E, Double_val, Double_val, GSL_MODE_val)
+ SF4(ellint_P, Double_val, Double_val, Double_val, GSL_MODE_val)
+-SF4(ellint_D, Double_val, Double_val, Double_val, GSL_MODE_val)
++//SF4(ellint_D, Double_val, Double_val, Double_val, GSL_MODE_val)
++SF3(ellint_D, Double_val, Double_val, GSL_MODE_val)
+ SF3(ellint_RC, Double_val, Double_val, GSL_MODE_val)
+ SF4(ellint_RD, Double_val, Double_val, Double_val, GSL_MODE_val)
+ SF4(ellint_RF, Double_val, Double_val, Double_val, GSL_MODE_val)
+@@ -452,6 +453,7 @@ SF1(legendre_Q1, Double_val)
+ SF2(legendre_Ql, Int_val, Double_val)
+
+ /* Associated Legendre Polynomials and Spherical Harmonics */
++/*
+ SF3(legendre_Plm, Int_val, Int_val, Double_val)
+ CAMLprim value
+ ml_gsl_sf_legendre_Plm_array(value lmax, value m, value x, value result_array)
+@@ -487,7 +489,7 @@ ml_gsl_sf_legendre_array_size(value lmax
+ ret = Val_int(gsl_ret);
+ CAMLreturn(ret);
+ }
+-
++*/
+ /* LOGARITHM and related functions */
+ SF1(log, Double_val)
+ SF1(log_abs, Double_val)