aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Algorithm-CurveFit/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:53:44 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-01 01:53:44 +0000
commit621307ff834153c234b05750e524cbe7cf94a24d (patch)
tree3d5f2ae0481b22bbb6e06f70ebe44e0c377b1d3d /math/p5-Algorithm-CurveFit/Makefile
parent762cf107f3908cd2c4020def4d1ed4c1bf7b29f9 (diff)
downloadports-621307ff834153c234b05750e524cbe7cf94a24d.tar.gz
ports-621307ff834153c234b05750e524cbe7cf94a24d.zip
Notes
Diffstat (limited to 'math/p5-Algorithm-CurveFit/Makefile')
-rw-r--r--math/p5-Algorithm-CurveFit/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/p5-Algorithm-CurveFit/Makefile b/math/p5-Algorithm-CurveFit/Makefile
new file mode 100644
index 000000000000..4861bfbae796
--- /dev/null
+++ b/math/p5-Algorithm-CurveFit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Algorithm-CurveFit
+# Date created: 2006-10-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-CurveFit
+PORTVERSION= 1.02
+CATEGORIES= math
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Nonlinear Least Squares Fitting
+
+RUN_DEPENDS= ${SITE_PERL}/Math/MatrixReal.pm:${PORTSDIR}/math/p5-MatrixReal \
+ ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::CurveFit.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from math/p5-Math-Symbolic
+IGNORE= requires 5.6.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>