aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Date-Handler
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-25 20:30:03 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-25 20:30:03 +0000
commit4db30879862cd70f58ee3e1adf2341a7e158130f (patch)
treee185a594bd387d683dce03dd3ab9072549c705b0 /math/p5-Date-Handler
parent6d061c9647876fff0c8936519b9c8de1bdfb5290 (diff)
downloadports-4db30879862cd70f58ee3e1adf2341a7e158130f.tar.gz
ports-4db30879862cd70f58ee3e1adf2341a7e158130f.zip
add p5-Date-Handler
Perl module for calculating time differences PR: 30071 Submitted by: Shell Hung <shell@shellhung.org>
Notes
Notes: svn path=/head/; revision=46901
Diffstat (limited to 'math/p5-Date-Handler')
-rw-r--r--math/p5-Date-Handler/Makefile25
-rw-r--r--math/p5-Date-Handler/distinfo1
-rw-r--r--math/p5-Date-Handler/pkg-comment1
-rw-r--r--math/p5-Date-Handler/pkg-descr6
-rw-r--r--math/p5-Date-Handler/pkg-plist11
5 files changed, 44 insertions, 0 deletions
diff --git a/math/p5-Date-Handler/Makefile b/math/p5-Date-Handler/Makefile
new file mode 100644
index 000000000000..95add961362b
--- /dev/null
+++ b/math/p5-Date-Handler/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Date-Handler
+# Date Created: 25 Aug 2001
+# Whom: Shell Hung <shell@shellhung.org>
+#
+# $FreeBSD$
+#
+# Considering this module for calculating date, so
+# I putted it into 'math' and not 'devel' or other
+
+PORTNAME= Date-Handler
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Date
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= shell@shellhung.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Date::Handler.3 Date::Handler::Delta.3 \
+ Date::Handler::Range.3 Date::Handler::Test.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Date-Handler/distinfo b/math/p5-Date-Handler/distinfo
new file mode 100644
index 000000000000..71f05359c089
--- /dev/null
+++ b/math/p5-Date-Handler/distinfo
@@ -0,0 +1 @@
+MD5 (Date-Handler-0.08.tar.gz) = 32e4d294495a020687f2adfbd4941b34
diff --git a/math/p5-Date-Handler/pkg-comment b/math/p5-Date-Handler/pkg-comment
new file mode 100644
index 000000000000..fe9c5e014bb9
--- /dev/null
+++ b/math/p5-Date-Handler/pkg-comment
@@ -0,0 +1 @@
+Perl module for calculating time differences
diff --git a/math/p5-Date-Handler/pkg-descr b/math/p5-Date-Handler/pkg-descr
new file mode 100644
index 000000000000..4c610ef48fc0
--- /dev/null
+++ b/math/p5-Date-Handler/pkg-descr
@@ -0,0 +1,6 @@
+Date::Handler is a container for dates that holds all the methods
+to transform itself from Timezone to Timezone and format itself.
+It uses operator overloading and Delta date objects to calculates
+time differences.
+
+WWW: http://search.cpan.org/search?dist=Date-Handler
diff --git a/math/p5-Date-Handler/pkg-plist b/math/p5-Date-Handler/pkg-plist
new file mode 100644
index 000000000000..d219319dbbf3
--- /dev/null
+++ b/math/p5-Date-Handler/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler.pm
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler.pod
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler/Constants.pm
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler/Delta.pm
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler/Range.pm
+lib/perl5/site_perl/%%PERL_VER%%/Date/Handler/Test.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Handler/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date/Handler
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Date 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Date/Handler
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Date 2>/dev/null || true