aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-BigInt-GMP
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-26 11:33:35 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-07-26 11:33:35 +0000
commitdc82b8d1fa2ef161071822a8eab6efee6d342395 (patch)
treefa61aaa0251ef8a811ef159d00524cd04ad8724e /math/p5-Math-BigInt-GMP
parent4002dc80c73e7e51cbb7321b3fff3504152de272 (diff)
downloadports-dc82b8d1fa2ef161071822a8eab6efee6d342395.tar.gz
ports-dc82b8d1fa2ef161071822a8eab6efee6d342395.zip
- Fix problem build with -lgmp
PR: ports/144406 Submitted by: Kimo <kimor79@yahoo.com> Approved by: wen@ (He is on vacation, I've his permission for commit your PR)
Notes
Notes: svn path=/head/; revision=258274
Diffstat (limited to 'math/p5-Math-BigInt-GMP')
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
index 4ce2ccf2687c..9085ca0efd0f 100644
--- a/math/p5-Math-BigInt-GMP/Makefile
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -24,4 +24,9 @@ CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
MAN3= Math::BigInt::GMP.3
+post-patch:
+ @${PERL} -pi -e "s!-lgmp!-L${LOCALBASE}/lib $$&!;" \
+ -e "if (/'LIBS'/) { print qq!'INC' => '-I${LOCALBASE}/include',!; }" \
+ ${WRKSRC}/Makefile.PL
+
.include <bsd.port.mk>