aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Complex
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:31:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:31:58 +0000
commit6a5d9cfbdd2628f3345226d13e07172d40c0410e (patch)
tree78c87e104cf9569663f6b2b881dec0067e800002 /math/p5-Math-Complex
parenta96e72de15a58ab684f0b5cfa30c240b5198674d (diff)
downloadports-6a5d9cfbdd2628f3345226d13e07172d40c0410e.tar.gz
ports-6a5d9cfbdd2628f3345226d13e07172d40c0410e.zip
This package lets you create and manipulate complex numbers. By default, Perl
limits itself to real numbers, but an extra use statement brings full complex support, along with a full set of mathematical functions typically associated with and/or extended to complex numbers. WWW: http://search.cpan.org/dist/Math-Complex/ PR: ports/119441 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Notes
Notes: svn path=/head/; revision=205437
Diffstat (limited to 'math/p5-Math-Complex')
-rw-r--r--math/p5-Math-Complex/Makefile22
-rw-r--r--math/p5-Math-Complex/distinfo3
-rw-r--r--math/p5-Math-Complex/pkg-descr6
-rw-r--r--math/p5-Math-Complex/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/math/p5-Math-Complex/Makefile b/math/p5-Math-Complex/Makefile
new file mode 100644
index 000000000000..d0307203af0c
--- /dev/null
+++ b/math/p5-Math-Complex/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-Complex
+# Date created: 2008-01-08
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Complex
+PORTVERSION= 1.42
+CATEGORIES= math
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Complex numbers and associated mathematical functions
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Math::Complex.3 \
+ Math::Trig.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Complex/distinfo b/math/p5-Math-Complex/distinfo
new file mode 100644
index 000000000000..327536294e50
--- /dev/null
+++ b/math/p5-Math-Complex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Complex-1.42.tar.gz) = d0825ce78ae8c7c9ee89ccca37418f72
+SHA256 (Math-Complex-1.42.tar.gz) = b121e72e6ee198861671fcf933df76a919560e77bd4ff0881359a3f179aa8b0e
+SIZE (Math-Complex-1.42.tar.gz) = 34624
diff --git a/math/p5-Math-Complex/pkg-descr b/math/p5-Math-Complex/pkg-descr
new file mode 100644
index 000000000000..ca7f4436b148
--- /dev/null
+++ b/math/p5-Math-Complex/pkg-descr
@@ -0,0 +1,6 @@
+This package lets you create and manipulate complex numbers. By default, Perl
+limits itself to real numbers, but an extra use statement brings full complex
+support, along with a full set of mathematical functions typically associated
+with and/or extended to complex numbers.
+
+WWW: http://search.cpan.org/dist/Math-Complex/
diff --git a/math/p5-Math-Complex/pkg-plist b/math/p5-Math-Complex/pkg-plist
new file mode 100644
index 000000000000..a983583f1d19
--- /dev/null
+++ b/math/p5-Math-Complex/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Complex/.packlist
+%%SITE_PERL%%/Math/Complex.pm
+%%SITE_PERL%%/Math/Trig.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Complex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math