aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-GMPq/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-22 21:29:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-22 21:29:37 +0000
commitb2d1c9878a913f67fe8fb4b340b73401bf44ee24 (patch)
tree0f9f4cf2810e3ffaa4bc6a65a174536b091093f3 /math/p5-Math-GMPq/Makefile
parenta8e379637c0e6565885974c16cbbc8bed99632de (diff)
downloadports-b2d1c9878a913f67fe8fb4b340b73401bf44ee24.tar.gz
ports-b2d1c9878a913f67fe8fb4b340b73401bf44ee24.zip
- Add p5-Math-GMPq 0.35
Math::GMPq is a bigrational module utilising the GNU MP (GMP) library. Basically this module simply wraps all of the mpq rational functions provided by that library. See the Math::GMPq test suite for some examples of usage. IMPORTANT: If your perl was built with '-Duse64bitint' you need to assign all integers larger than 52-bit in a 'use integer;' block. Failure to do so can result in the creation of the variable as an NV (rather than an IV) - with a resultant loss of precision. WWW: http://search.cpan.org/dist/Math-GMPq/
Notes
Notes: svn path=/head/; revision=299793
Diffstat (limited to 'math/p5-Math-GMPq/Makefile')
-rw-r--r--math/p5-Math-GMPq/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/p5-Math-GMPq/Makefile b/math/p5-Math-GMPq/Makefile
new file mode 100644
index 000000000000..a6fbf51a8876
--- /dev/null
+++ b/math/p5-Math-GMPq/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Math-GMPq
+# Date created: 2011-11-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-GMPq
+PORTVERSION= 0.35
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SISYPHUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl interface to the GMP library rational (mpq) functions
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
+
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
+PERL_CONFIGURE= yes
+
+MAN3= Math::GMPq.3
+
+.include <bsd.port.mk>