aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Int128
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-25 15:27:10 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-25 15:27:10 +0000
commit6c2be351c950221b43167f413a7f53e7480effc0 (patch)
tree71940d8a19d32b6c62d75ed8019890d3fdd9d15e /math/p5-Math-Int128
parent4640de2eb843274c5a2985b57a04575241d83d29 (diff)
downloadports-6c2be351c950221b43167f413a7f53e7480effc0.tar.gz
ports-6c2be351c950221b43167f413a7f53e7480effc0.zip
- update to 0.12
- split logic of compilter detection: need clang 3.2+ or gcc 4.4+ - mark not for ARCH i386 PR: 180487 Submitted by: Kurt Jaeger <fbsd-ports@opsec.eu> Approved by: Kurt Jaeger <fbsd-ports@opsec.eu> (maintainer)
Notes
Notes: svn path=/head/; revision=325349
Diffstat (limited to 'math/p5-Math-Int128')
-rw-r--r--math/p5-Math-Int128/Makefile20
-rw-r--r--math/p5-Math-Int128/distinfo4
-rw-r--r--math/p5-Math-Int128/files/patch-Makefile.PL23
-rw-r--r--math/p5-Math-Int128/pkg-plist4
4 files changed, 18 insertions, 33 deletions
diff --git a/math/p5-Math-Int128/Makefile b/math/p5-Math-Int128/Makefile
index f230395cc04d..e292a6ff0efd 100644
--- a/math/p5-Math-Int128/Makefile
+++ b/math/p5-Math-Int128/Makefile
@@ -3,8 +3,7 @@
#
PORTNAME= Math-Int128
-PORTVERSION= 0.07
-PORTREVISION= 1
+PORTVERSION= 0.12
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,15 +13,24 @@ COMMENT= Manipulate 128 bits integers in Perl
LICENSE= ART10
-BUILD_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
-RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+BUILD_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
USES= perl5
USE_PERL5= configure
-USE_GCC= yes
+NOT_FOR_ARCHS= i386
MAN3= Math::Int128.3 \
Math::Int128::die_on_overflow.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# need clang 3.2+ or gcc 4.4+
+.if exists(/usr/bin/clang) && ${OSVERSION} > 901505
+CC= /usr/bin/clang
+.else
+USE_GCC= 4.4+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Int128/distinfo b/math/p5-Math-Int128/distinfo
index d01abc3f0bfd..2b60e899c9bb 100644
--- a/math/p5-Math-Int128/distinfo
+++ b/math/p5-Math-Int128/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Math-Int128-0.07.tar.gz) = 5401691a22f723d3834c086b76e933b5bf01ff2c69d6e37b675e75cfc664efe9
-SIZE (Math-Int128-0.07.tar.gz) = 60412
+SHA256 (Math-Int128-0.12.tar.gz) = 09075e44aba51722d8f464e3e15ecbab291e3fb58d3bfc3d124a53b29f7dd876
+SIZE (Math-Int128-0.12.tar.gz) = 61847
diff --git a/math/p5-Math-Int128/files/patch-Makefile.PL b/math/p5-Math-Int128/files/patch-Makefile.PL
deleted file mode 100644
index 5999148b9446..000000000000
--- a/math/p5-Math-Int128/files/patch-Makefile.PL
+++ /dev/null
@@ -1,23 +0,0 @@
---- Makefile.PL 2012-12-10 21:27:04.000000000 +0100
-+++ /tmp/Makefile.PL 2012-12-11 07:17:41.000000000 +0100
-@@ -14,13 +14,14 @@
- OBJECT => '$(O_FILES)',
- );
-
--my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
-+# my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
-+my $cc = 'gcc44';
- my $cc_version = `$cc --version --verbose 2>&1`;
--unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
-- unlink $mm->{MAKEFILE};
-- die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
--}
--print "GNU C compiler version $1 found, good!\n";
-+#unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
-+# unlink $mm->{MAKEFILE};
-+# die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
-+#}
-+#print "GNU C compiler version $1 found, good!\n";
-
- package MY;
-
diff --git a/math/p5-Math-Int128/pkg-plist b/math/p5-Math-Int128/pkg-plist
index 26e85a27a4a4..2946f8b48a7a 100644
--- a/math/p5-Math-Int128/pkg-plist
+++ b/math/p5-Math-Int128/pkg-plist
@@ -4,6 +4,6 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math