aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Int128
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2012-12-20 08:47:10 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2012-12-20 08:47:10 +0000
commite8f1c73d0798650d44f0f00e5fd3b01daf4fa320 (patch)
treed81619f5841416a0e0efd71042291d3ad396e1ec /math/p5-Math-Int128
parent06f984a30b6e5787911d7c64e5693b2c1804e279 (diff)
downloadports-e8f1c73d0798650d44f0f00e5fd3b01daf4fa320.tar.gz
ports-e8f1c73d0798650d44f0f00e5fd3b01daf4fa320.zip
Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.
WWW: http://search.cpan.org/dist/Math-Int64/ PR: ports/174359 Submitted by: fbsd-ports@opsec.eu
Notes
Notes: svn path=/head/; revision=309299
Diffstat (limited to 'math/p5-Math-Int128')
-rw-r--r--math/p5-Math-Int128/Makefile26
-rw-r--r--math/p5-Math-Int128/distinfo2
-rw-r--r--math/p5-Math-Int128/files/patch-Makefile.PL23
-rw-r--r--math/p5-Math-Int128/pkg-descr3
-rw-r--r--math/p5-Math-Int128/pkg-plist9
5 files changed, 63 insertions, 0 deletions
diff --git a/math/p5-Math-Int128/Makefile b/math/p5-Math-Int128/Makefile
new file mode 100644
index 000000000000..13ba86389371
--- /dev/null
+++ b/math/p5-Math-Int128/Makefile
@@ -0,0 +1,26 @@
+# Created by: Kurt Jaeger <fbsd-ports@opsec.eu>
+# $FreeBSD$
+#
+
+PORTNAME= Math-Int128
+PORTVERSION= 0.07
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= Manipulate 128 bits integers in Perl
+
+LICENSE= ART10
+
+BUILD_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+RUN_DEPENDS= p5-Math-Int64>=0.28:${PORTSDIR}/math/p5-Math-Int64
+
+PERL_CONFIGURE= yes
+
+USE_GCC= 4.4+
+
+MAN3= Math::Int128.3 \
+ Math::Int128::die_on_overflow.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Int128/distinfo b/math/p5-Math-Int128/distinfo
new file mode 100644
index 000000000000..d01abc3f0bfd
--- /dev/null
+++ b/math/p5-Math-Int128/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-Int128-0.07.tar.gz) = 5401691a22f723d3834c086b76e933b5bf01ff2c69d6e37b675e75cfc664efe9
+SIZE (Math-Int128-0.07.tar.gz) = 60412
diff --git a/math/p5-Math-Int128/files/patch-Makefile.PL b/math/p5-Math-Int128/files/patch-Makefile.PL
new file mode 100644
index 000000000000..5999148b9446
--- /dev/null
+++ b/math/p5-Math-Int128/files/patch-Makefile.PL
@@ -0,0 +1,23 @@
+--- Makefile.PL 2012-12-10 21:27:04.000000000 +0100
++++ /tmp/Makefile.PL 2012-12-11 07:17:41.000000000 +0100
+@@ -14,13 +14,14 @@
+ OBJECT => '$(O_FILES)',
+ );
+
+-my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
++# my $cc = (grep defined, $mm->{CC}, $Config{cc}, 'cc')[0];
++my $cc = 'gcc44';
+ my $cc_version = `$cc --version --verbose 2>&1`;
+-unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
+- unlink $mm->{MAKEFILE};
+- die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
+-}
+-print "GNU C compiler version $1 found, good!\n";
++#unless ($cc_version =~ /^GNU\s+C\s+\([^)]*\)\s+version\s+(4\.(\d+)\S*)/im and $2 >= 4) {
++# unlink $mm->{MAKEFILE};
++# die "This module requires version 4.4 or above of the GCC compiler.\nAborting!\n\n"
++#}
++#print "GNU C compiler version $1 found, good!\n";
+
+ package MY;
+
diff --git a/math/p5-Math-Int128/pkg-descr b/math/p5-Math-Int128/pkg-descr
new file mode 100644
index 000000000000..6ca672c59011
--- /dev/null
+++ b/math/p5-Math-Int128/pkg-descr
@@ -0,0 +1,3 @@
+Math::Int64 adds support for 64 bit integers, signed and unsigned, to Perl.
+
+WWW: http://search.cpan.org/dist/Math-Int64/
diff --git a/math/p5-Math-Int128/pkg-plist b/math/p5-Math-Int128/pkg-plist
new file mode 100644
index 000000000000..26e85a27a4a4
--- /dev/null
+++ b/math/p5-Math-Int128/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128/die_on_overflow.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128/Int128.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Int128
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Int128
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math