aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-MPFR
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-06 15:40:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-09-06 15:40:00 +0000
commitcf8d6266243518a8be7b6f6b5631467b9cb2ba5f (patch)
treee39bd289ef64806d3384d4bf8454af8140cf61da /math/p5-Math-MPFR
parente10e7bfef2b31d0713179f87e38a277e28e4f77e (diff)
downloadports-cf8d6266243518a8be7b6f6b5631467b9cb2ba5f.tar.gz
ports-cf8d6266243518a8be7b6f6b5631467b9cb2ba5f.zip
Convert REINPLACE_CMD to patch file
Notes
Notes: svn path=/head/; revision=547853
Diffstat (limited to 'math/p5-Math-MPFR')
-rw-r--r--math/p5-Math-MPFR/Makefile3
-rw-r--r--math/p5-Math-MPFR/files/patch-Makefile.PL20
2 files changed, 20 insertions, 3 deletions
diff --git a/math/p5-Math-MPFR/Makefile b/math/p5-Math-MPFR/Makefile
index acd81fe08de4..57c3ff3a76e0 100644
--- a/math/p5-Math-MPFR/Makefile
+++ b/math/p5-Math-MPFR/Makefile
@@ -23,9 +23,6 @@ TEST_DEPENDS= p5-Math-GMP>=0:math/p5-Math-GMP \
USES= localbase perl5
USE_PERL5= configure
-post-patch:
- @${REINPLACE_CMD} -e 's| -lquadmath||' ${WRKSRC}/Makefile.PL
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/MPFR/MPFR.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/MPFR/Prec/Prec.so
diff --git a/math/p5-Math-MPFR/files/patch-Makefile.PL b/math/p5-Math-MPFR/files/patch-Makefile.PL
new file mode 100644
index 000000000000..59c4ca165819
--- /dev/null
+++ b/math/p5-Math-MPFR/files/patch-Makefile.PL
@@ -0,0 +1,20 @@
+--- Makefile.PL.orig 2020-07-13 12:00:38 UTC
++++ Makefile.PL
+@@ -193,7 +193,7 @@ else { # we still need to determine whether__float128
+ $mycc = defined($Config{cc}) ? $Config{cc} : 'cc';
+ }
+
+- $mylibs = '-lmpfr -lgmp -lquadmath' unless $mylibs;
++ $mylibs = '-lmpfr -lgmp' unless $mylibs;
+
+ # Include $mylibs to ensure that -lquadmath is locatable.
+ my $out = `$mycc -o have_f128.exe -x c have_f128.in $mylibs 2>&1`;
+@@ -336,7 +336,7 @@ my %options = (
+ ABSTRACT => 'Perl interface to the MPFR (floating point) library',
+ DEFINE => $defines,
+ LIBS => [
+- '-lmpfr -lgmp -lquadmath'
++ '-lmpfr -lgmp'
+ ],
+ PREREQ_PM => {
+ 'Test::More' => '0.88',