aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Random
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-28 18:15:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-28 18:15:42 +0000
commit8f270685f0d6da1a2cd193674f1da894f59984f4 (patch)
tree2fc08e59fdffcd6106594d6a79d2fc441ab6754a /math/p5-Math-Random
parentc14a363cb4cf2eba84dcacf29500c33e3d26a713 (diff)
downloadports-8f270685f0d6da1a2cd193674f1da894f59984f4.tar.gz
ports-8f270685f0d6da1a2cd193674f1da894f59984f4.zip
- Fix shebangs
- Strip library Approved by: portmgr blanket MFH: 2015Q2
Notes
Notes: svn path=/head/; revision=387761
Diffstat (limited to 'math/p5-Math-Random')
-rw-r--r--math/p5-Math-Random/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/p5-Math-Random/Makefile b/math/p5-Math-Random/Makefile
index 95f38b023d80..a1a723d5dfd9 100644
--- a/math/p5-Math-Random/Makefile
+++ b/math/p5-Math-Random/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Math-Random
PORTVERSION= 0.71
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,7 +11,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Random number generators
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= example.pl
USE_PERL5= configure
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/Random/Random.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/Random/Random.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/Random/Random.so
+
.include <bsd.port.mk>