aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Symbolic-Custom-Pattern
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:43:24 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:43:24 +0000
commit0c61840fb0ae723c2549707015af7ccf853adff1 (patch)
tree09ef02d687a0d43eef6d9470bdb795542a3ffe60 /math/p5-Math-Symbolic-Custom-Pattern
parent60f280a3e3e416b41554b853813903880a524741 (diff)
downloadports-0c61840fb0ae723c2549707015af7ccf853adff1.tar.gz
ports-0c61840fb0ae723c2549707015af7ccf853adff1.zip
Adding port math/p5-Math-Symbolic-Custom-Pattern, Pattern matching on Math::Symbolic trees
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162453
Diffstat (limited to 'math/p5-Math-Symbolic-Custom-Pattern')
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/Makefile33
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/distinfo3
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/pkg-descr16
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/pkg-plist11
4 files changed, 63 insertions, 0 deletions
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/Makefile b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
new file mode 100644
index 000000000000..c76d95caeb0c
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Math-Symbolic-Custom-Pattern
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic-Custom-Pattern
+PORTVERSION= 1.11
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Pattern matching on Math::Symbolic trees
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic::Custom::Pattern.3 \
+ Math::Symbolic::Custom::Pattern::Export.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/distinfo b/math/p5-Math-Symbolic-Custom-Pattern/distinfo
new file mode 100644
index 000000000000..57508262fac8
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Pattern/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Symbolic-Custom-Pattern-1.11.tar.gz) = 8927d26d3f4597a97999ebbe93f4fd30
+SHA256 (Math-Symbolic-Custom-Pattern-1.11.tar.gz) = 8b4cf883595d79bfdc2651cf6e5190bd0692f8147a691c346dac6ca2a953fc46
+SIZE (Math-Symbolic-Custom-Pattern-1.11.tar.gz) = 8798
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/pkg-descr b/math/p5-Math-Symbolic-Custom-Pattern/pkg-descr
new file mode 100644
index 000000000000..54d31505e650
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Pattern/pkg-descr
@@ -0,0 +1,16 @@
+This module is an extension to the Math::Symbolic module. A basic
+familiarity with that module is required.
+
+The Math::Symbolic::Custom::Pattern module implements pattern matching
+routines on Math::Symbolic trees. The patterns itself are constructed from
+Math::Symbolic trees with just a few variables which have a special
+meaning.
+
+The module provides two interfaces. You can use the new() and match()
+methods this class provides, or you can use the to_pattern() and
+is_of_form() methods on any Math::Symbolic tree. (Exported by the
+Math::Symbolic::Custom::Pattern::Export module. Refer to that module for
+details on is_of_form().)
+
+WWW: http://search.cpan.org/dist/Math-Symbolic-Custom-Pattern
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/pkg-plist b/math/p5-Math-Symbolic-Custom-Pattern/pkg-plist
new file mode 100644
index 000000000000..b886aab74ef2
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Pattern/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Math/Symbolic/Custom/Pattern.pm
+%%SITE_PERL%%/Math/Symbolic/Custom/Pattern/Export.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Pattern/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Pattern
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/Math/Symbolic/Custom/Pattern
+@dirrmtry %%SITE_PERL%%/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/Math