aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Symbolic-Custom-Transformation
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:59:04 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:59:04 +0000
commit49011927726ae8d485b6510d63ccd66e2b71e37e (patch)
tree89317124de554e5b370645e6a6f5be4bf99b833b /math/p5-Math-Symbolic-Custom-Transformation
parent9e1392e110229e3de87897a5f92d0e7ace4e5064 (diff)
downloadports-49011927726ae8d485b6510d63ccd66e2b71e37e.tar.gz
ports-49011927726ae8d485b6510d63ccd66e2b71e37e.zip
Adding port math/p5-Math-Symbolic-Custom-Transformation, Transform Math::Symbolic trees
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162457
Diffstat (limited to 'math/p5-Math-Symbolic-Custom-Transformation')
-rw-r--r--math/p5-Math-Symbolic-Custom-Transformation/Makefile32
-rw-r--r--math/p5-Math-Symbolic-Custom-Transformation/distinfo3
-rw-r--r--math/p5-Math-Symbolic-Custom-Transformation/pkg-descr20
-rw-r--r--math/p5-Math-Symbolic-Custom-Transformation/pkg-plist9
4 files changed, 64 insertions, 0 deletions
diff --git a/math/p5-Math-Symbolic-Custom-Transformation/Makefile b/math/p5-Math-Symbolic-Custom-Transformation/Makefile
new file mode 100644
index 000000000000..f659d097ac1e
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Transformation/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-Symbolic-Custom-Transformation
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Symbolic-Custom-Transformation
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Transform Math::Symbolic trees
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/Symbolic/Custom/Pattern.pm:${PORTSDIR}/math/p5-Math-Symbolic-Custom-Pattern
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Symbolic::Custom::Transformation.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Transformation/distinfo b/math/p5-Math-Symbolic-Custom-Transformation/distinfo
new file mode 100644
index 000000000000..8de7e4019a1d
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Transformation/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Symbolic-Custom-Transformation-1.01.tar.gz) = 24a17c3ae1f47b246c503667e385eb3f
+SHA256 (Math-Symbolic-Custom-Transformation-1.01.tar.gz) = c096cc13106af8d9e3c935c2ad05cbbb9ada36911a5f42dada15cd42c7633c21
+SIZE (Math-Symbolic-Custom-Transformation-1.01.tar.gz) = 9780
diff --git a/math/p5-Math-Symbolic-Custom-Transformation/pkg-descr b/math/p5-Math-Symbolic-Custom-Transformation/pkg-descr
new file mode 100644
index 000000000000..8f9ece2bdcaf
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Transformation/pkg-descr
@@ -0,0 +1,20 @@
+Math::Symbolic::Custom::Transformation is an extension to the
+Math::Symbolic module. You're assumed to be remotely familiar with that
+module throughout the documentation.
+
+This package implements transformations of Math::Symbolic trees using
+Math::Symbolic trees. I'll try to explain what this means in the following
+paragraphs.
+
+Until now, in order to be able to inspect a Math::Symbolic tree, one had
+to use the low-level Math::Symbolic interface like comparing the top
+node's term type with a constant (such as T_OPERATOR) and then its
+operator type with more constants. This has changed with the release of
+Math::Symbolic::Custom::Pattern.
+
+To modify the tree, you had to use equally low-level or even
+encapsulation-breaking methods. This is meant to be changed by this
+distribution.
+
+WWW: http://search.cpan.org/dist/Math-Symbolic-Custom-Transformation
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-Symbolic-Custom-Transformation/pkg-plist b/math/p5-Math-Symbolic-Custom-Transformation/pkg-plist
new file mode 100644
index 000000000000..54cdd5406678
--- /dev/null
+++ b/math/p5-Math-Symbolic-Custom-Transformation/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Math/Symbolic/Custom/Transformation.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Transformation/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom/Transformation
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Symbolic/Custom
+@dirrmtry %%SITE_PERL%%/Math/Symbolic
+@dirrmtry %%SITE_PERL%%/Math