aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:20:12 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:20:12 +0000
commitcc977fa0810cf11473f1160f13a7dd9caf3a379e (patch)
tree13ae0148a1846fb7b3a105bf3a9507ffd601435f /math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
parent23fec79211d8eab4bf96387fdba1fe36b9f751b5 (diff)
downloadports-cc977fa0810cf11473f1160f13a7dd9caf3a379e.tar.gz
ports-cc977fa0810cf11473f1160f13a7dd9caf3a379e.zip
Adding port math/p5-Math-SymbolicX-Statistics-Distributions, Statistical distributions for Math::Symbolic objects
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162445
Diffstat (limited to 'math/p5-Math-SymbolicX-Statistics-Distributions/Makefile')
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
new file mode 100644
index 000000000000..3eaf3fd60d03
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-Statistics-Distributions
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Statistics-Distributions
+PORTVERSION= 1.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Statistical distributions
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Statistics::Distributions.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>