aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-TrulyRandom
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 12:27:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 12:27:50 +0000
commit43d9a595244fd43527e8fc318b2625970bc0898b (patch)
treee7a076cca7abb306a4b9f7b058b03797850d5386 /math/p5-Math-TrulyRandom
parentbff00efd7be08e1aa1c2dc37e1a581fcbf0becf4 (diff)
downloadports-43d9a595244fd43527e8fc318b2625970bc0898b.tar.gz
ports-43d9a595244fd43527e8fc318b2625970bc0898b.zip
- Support staging
- Strip shared object - Don't install license file into DOCSDIR but define LICENSE
Notes
Notes: svn path=/head/; revision=343059
Diffstat (limited to 'math/p5-Math-TrulyRandom')
-rw-r--r--math/p5-Math-TrulyRandom/Makefile19
-rw-r--r--math/p5-Math-TrulyRandom/pkg-plist5
2 files changed, 12 insertions, 12 deletions
diff --git a/math/p5-Math-TrulyRandom/Makefile b/math/p5-Math-TrulyRandom/Makefile
index 712fd492f206..d558f6b92016 100644
--- a/math/p5-Math-TrulyRandom/Makefile
+++ b/math/p5-Math-TrulyRandom/Makefile
@@ -10,18 +10,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= anders@FreeBSD.org
COMMENT= Perl interface to a truly random number generator function
+LICENSE= BSD3CLAUSE
+
USES= perl5
USE_PERL5= configure
-MAN3= Math::TrulyRandom.3
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d -m 0755 ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/truerand.c ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/truerand.h ${DOCSDIR}/
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/truerand.c ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/truerand.h ${STAGEDIR}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Math/TrulyRandom/TrulyRandom.so
.include <bsd.port.mk>
diff --git a/math/p5-Math-TrulyRandom/pkg-plist b/math/p5-Math-TrulyRandom/pkg-plist
index e0ddae05cacf..814746051818 100644
--- a/math/p5-Math-TrulyRandom/pkg-plist
+++ b/math/p5-Math-TrulyRandom/pkg-plist
@@ -3,10 +3,7 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.so
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/.packlist
-%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
-%%PORTDOCS%%%%DOCSDIR%%/truerand.c
-%%PORTDOCS%%%%DOCSDIR%%/truerand.h
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PERL5_MAN3%%/Math::TrulyRandom.3.gz
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math