aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-TrulyRandom
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /math/p5-Math-TrulyRandom
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'math/p5-Math-TrulyRandom')
-rw-r--r--math/p5-Math-TrulyRandom/Makefile3
-rw-r--r--math/p5-Math-TrulyRandom/pkg-plist10
2 files changed, 5 insertions, 8 deletions
diff --git a/math/p5-Math-TrulyRandom/Makefile b/math/p5-Math-TrulyRandom/Makefile
index 191ccd59d701..7ba4d27f23a5 100644
--- a/math/p5-Math-TrulyRandom/Makefile
+++ b/math/p5-Math-TrulyRandom/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Math-TrulyRandom
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -25,6 +26,6 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/truerand.c ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/truerand.h ${STAGEDIR}${DOCSDIR}
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Math/TrulyRandom/TrulyRandom.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Math/TrulyRandom/TrulyRandom.so
.include <bsd.port.mk>
diff --git a/math/p5-Math-TrulyRandom/pkg-plist b/math/p5-Math-TrulyRandom/pkg-plist
index ccb93ba448e6..499f64703023 100644
--- a/math/p5-Math-TrulyRandom/pkg-plist
+++ b/math/p5-Math-TrulyRandom/pkg-plist
@@ -1,8 +1,4 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Math/TrulyRandom.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Math/TrulyRandom.pod
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/.packlist
+%%SITE_ARCH%%/Math/TrulyRandom.pm
+%%SITE_ARCH%%/Math/TrulyRandom.pod
+%%SITE_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.so
%%PERL5_MAN3%%/Math::TrulyRandom.3.gz
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/TrulyRandom
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math