aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Vec
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2005-09-01 09:22:02 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2005-09-01 09:22:02 +0000
commit94bec01f5e3b3d3b89dab5dfee7256dbd7c2ff99 (patch)
treecad2e14bbfe9dc7d568ad5f6ab96e67704eb7f6a /math/p5-Math-Vec
parent48c80046e913a6856fff2f51cd96a6baaafeb06d (diff)
downloadports-94bec01f5e3b3d3b89dab5dfee7256dbd7c2ff99.tar.gz
ports-94bec01f5e3b3d3b89dab5dfee7256dbd7c2ff99.zip
- Unbreak on 4.x by using "use vars" instead of "our".
- Add forgotten $PKGNAMEPREFIX. Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=141685
Diffstat (limited to 'math/p5-Math-Vec')
-rw-r--r--math/p5-Math-Vec/Makefile6
-rw-r--r--math/p5-Math-Vec/files/patch-Vec.pm10
2 files changed, 13 insertions, 3 deletions
diff --git a/math/p5-Math-Vec/Makefile b/math/p5-Math-Vec/Makefile
index 08de82f2bffe..027c49ccd515 100644
--- a/math/p5-Math-Vec/Makefile
+++ b/math/p5-Math-Vec/Makefile
@@ -7,9 +7,11 @@
PORTNAME= Math-Vec
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/E/EW/EWILHELM/Math
+PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Object-Oriented Vector Math Methods in Perl
@@ -17,6 +19,4 @@ COMMENT= Object-Oriented Vector Math Methods in Perl
PERL_CONFIGURE= yes
MAN3= Math::Vec.3
-.include <bsd.port.pre.mk>
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Vec/files/patch-Vec.pm b/math/p5-Math-Vec/files/patch-Vec.pm
new file mode 100644
index 000000000000..c6929952a7ee
--- /dev/null
+++ b/math/p5-Math-Vec/files/patch-Vec.pm
@@ -0,0 +1,10 @@
+--- Vec.pm.orig Thu Sep 1 18:16:13 2005
++++ Vec.pm Thu Sep 1 18:16:43 2005
+@@ -1,5 +1,6 @@
+ package Math::Vec;
+-our $VERSION = '0.02';
++use vars qw($VERSION);
++$VERSION = '0.02';
+
+ =pod
+