aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Parse-Range
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2012-11-26 09:35:49 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2012-11-26 09:35:49 +0000
commite220658a79572b9f75b678919084e0e80adce890 (patch)
treecd880492f60c1c6fdfacfaf849eecfcf385b65ff /math/p5-Parse-Range
parent000cbdaf9f22222b83456d0252ce036e01d26752 (diff)
downloadports-e220658a79572b9f75b678919084e0e80adce890.tar.gz
ports-e220658a79572b9f75b678919084e0e80adce890.zip
This module parses range definitions and returns
an array of individual numbers. WWW: http://search.cpan.org/dist/Parse-Range/ PR: ports/173280 Submitted by: pauls@utdallas.edu Feature safe: yes
Notes
Notes: svn path=/head/; revision=307768
Diffstat (limited to 'math/p5-Parse-Range')
-rw-r--r--math/p5-Parse-Range/Makefile29
-rw-r--r--math/p5-Parse-Range/distinfo2
-rw-r--r--math/p5-Parse-Range/pkg-descr4
-rw-r--r--math/p5-Parse-Range/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/math/p5-Parse-Range/Makefile b/math/p5-Parse-Range/Makefile
new file mode 100644
index 000000000000..5bc5a9b8e288
--- /dev/null
+++ b/math/p5-Parse-Range/Makefile
@@ -0,0 +1,29 @@
+# Created by: pauls@utdallas.edu
+# $FreeBSD$
+
+PORTNAME= Parse-Range
+PORTVERSION= 0.96
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PERLER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pauls@utdallas.edu
+COMMENT= Parses range definitions and returns an array
+
+LICENSE= ART10 BSD
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Module-Build>=0.4:${PORTSDIR}/devel/p5-Module-Build \
+ p5-ExtUtils-MakeMaker>=6.6:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
+ p5-List-MoreUtils>=0.3:${PORTSDIR}/lang/p5-List-MoreUtils
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::Range.3
+
+.include <bsd.port.pre.mk>
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Parse-Range/distinfo b/math/p5-Parse-Range/distinfo
new file mode 100644
index 000000000000..1d69203a2a88
--- /dev/null
+++ b/math/p5-Parse-Range/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parse-Range-0.96.tar.gz) = 6ef06ca8db01a5ade311ab583d1a9bcee89b54aa417c23c2096db3d163fc005b
+SIZE (Parse-Range-0.96.tar.gz) = 6074
diff --git a/math/p5-Parse-Range/pkg-descr b/math/p5-Parse-Range/pkg-descr
new file mode 100644
index 000000000000..fe56d92e090f
--- /dev/null
+++ b/math/p5-Parse-Range/pkg-descr
@@ -0,0 +1,4 @@
+This module parses range definitions and returns
+an array of individual numbers.
+
+WWW: http://search.cpan.org/dist/Parse-Range/
diff --git a/math/p5-Parse-Range/pkg-plist b/math/p5-Parse-Range/pkg-plist
new file mode 100644
index 000000000000..46bbe3ff2df1
--- /dev/null
+++ b/math/p5-Parse-Range/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Parse/Range.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Range/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Range
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrm %%SITE_PERL%%/Parse