aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Roman
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 00:33:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 00:33:47 +0000
commitee58d24168ffb0d719ba672271d5e987986083e4 (patch)
treeff2cbf491011724f4e11eb46f83bf9fc87053fd1 /math/p5-Roman
parent0ec397210c326ebfc321bc1222bcf6fdde7b99a6 (diff)
downloadports-ee58d24168ffb0d719ba672271d5e987986083e4.tar.gz
ports-ee58d24168ffb0d719ba672271d5e987986083e4.zip
New ports: devel/p5-Date-Roman, math/p5-Roman
The math/p5-Roman port will convert 'ordinary' Arabic numerals into their Roman couterparts. Comes in handy when trying to decipher copyright messages on BBC. The devel/p5-Date-Roman port translates 'modern' dates into the format used by the ancient Romans. Makes for an interesting addition to e-mail headers. PR: ports/47148 Submitted by: Philip Paeps <philip@paeps.cx>
Notes
Notes: svn path=/head/; revision=74709
Diffstat (limited to 'math/p5-Roman')
-rw-r--r--math/p5-Roman/Makefile24
-rw-r--r--math/p5-Roman/distinfo1
-rw-r--r--math/p5-Roman/pkg-comment1
-rw-r--r--math/p5-Roman/pkg-descr4
-rw-r--r--math/p5-Roman/pkg-plist1
5 files changed, 31 insertions, 0 deletions
diff --git a/math/p5-Roman/Makefile b/math/p5-Roman/Makefile
new file mode 100644
index 000000000000..18dc0d0b550f
--- /dev/null
+++ b/math/p5-Roman/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Roman
+# Date created: 16 January 2003
+# Whom: Philip Paeps <philip@paeps.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Roman
+PORTVERSION= 1.1
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Roman
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= philip@paeps.cx
+
+NO_BUILD= yes
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+do-install:
+ ${CP} ${WRKSRC}/Roman.pm ${SITE_PERL}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Roman/distinfo b/math/p5-Roman/distinfo
new file mode 100644
index 000000000000..70951b7ee27f
--- /dev/null
+++ b/math/p5-Roman/distinfo
@@ -0,0 +1 @@
+MD5 (Roman-1.1.tar.gz) = 67b0e6affdc50fdf28cfc438c045fd9b
diff --git a/math/p5-Roman/pkg-comment b/math/p5-Roman/pkg-comment
new file mode 100644
index 000000000000..5ef66bf7a35a
--- /dev/null
+++ b/math/p5-Roman/pkg-comment
@@ -0,0 +1 @@
+Perl module to convert between Arabic and Roman numerals
diff --git a/math/p5-Roman/pkg-descr b/math/p5-Roman/pkg-descr
new file mode 100644
index 000000000000..6745d345fe88
--- /dev/null
+++ b/math/p5-Roman/pkg-descr
@@ -0,0 +1,4 @@
+A Perl package providing the functionality to convert between
+Arabic and Roman numerals.
+
+WWW: http://search.cpan.org/author/OZAWA/Roman-1.1/Roman.pm
diff --git a/math/p5-Roman/pkg-plist b/math/p5-Roman/pkg-plist
new file mode 100644
index 000000000000..240c3d07da15
--- /dev/null
+++ b/math/p5-Roman/pkg-plist
@@ -0,0 +1 @@
+lib/perl5/site_perl/%%PERL_VER%%/Roman.pm