aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Set-Partition
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-06 00:40:10 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-06 00:40:10 +0000
commit2ca026de42965661902a304af1b9bdac457b2177 (patch)
tree729711f87576ce04f75267df5aa8be81feeaaf64 /math/p5-Set-Partition
parent86a03ac7939020bf8cffb50dcd47aa4f5f02cc91 (diff)
downloadports-2ca026de42965661902a304af1b9bdac457b2177.tar.gz
ports-2ca026de42965661902a304af1b9bdac457b2177.zip
Notes
Diffstat (limited to 'math/p5-Set-Partition')
-rw-r--r--math/p5-Set-Partition/Makefile34
-rw-r--r--math/p5-Set-Partition/distinfo3
-rw-r--r--math/p5-Set-Partition/pkg-descr12
-rw-r--r--math/p5-Set-Partition/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/math/p5-Set-Partition/Makefile b/math/p5-Set-Partition/Makefile
new file mode 100644
index 000000000000..6fd076e63bcc
--- /dev/null
+++ b/math/p5-Set-Partition/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Set-Partition
+# Date created: 05 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-Partition
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Enumerate all arrangements of a set in fixed subsets
+
+MAN3= Set::Partition.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+#IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+#post-patch:
+# @${PERL} -pi -e 's/^our (\$$VERSION)/use vars qw($$1); $$1/g;' \
+# -e '$$_ = "" if /use warnings/;' \
+# ${WRKSRC}/lib/GraphViz/Traverse.pm \
+# ${WRKSRC}/t/*.t \
+# ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Set-Partition/distinfo b/math/p5-Set-Partition/distinfo
new file mode 100644
index 000000000000..4d73d9417ba7
--- /dev/null
+++ b/math/p5-Set-Partition/distinfo
@@ -0,0 +1,3 @@
+MD5 (Set-Partition-0.02.tar.gz) = 592308e0393b5d9698a87041a07f5019
+SHA256 (Set-Partition-0.02.tar.gz) = f5309861e017697bafbf4ba33093265e32db699d31d480c24b729caffc4f0456
+SIZE (Set-Partition-0.02.tar.gz) = 6935
diff --git a/math/p5-Set-Partition/pkg-descr b/math/p5-Set-Partition/pkg-descr
new file mode 100644
index 000000000000..5fa8e1f69f74
--- /dev/null
+++ b/math/p5-Set-Partition/pkg-descr
@@ -0,0 +1,12 @@
+Set::Partition takes a list or hash of elements and a list numbers that
+represent the sizes of the partitions into which the list of elements
+should be arranged.
+
+The resulting object can then be used as an iterator which returns a
+reference to an array of lists, that represents the original list arranged
+according to the given partitioning. All possible arrangements are
+returned, and the object returns undef when the entire combination space
+has been exhausted.
+
+WWW: http://search.cpan.org/dist/Set-Partition
+Author: David Landgren (http://www.landgren.net/perl/)
diff --git a/math/p5-Set-Partition/pkg-plist b/math/p5-Set-Partition/pkg-plist
new file mode 100644
index 000000000000..3bb71339dbf9
--- /dev/null
+++ b/math/p5-Set-Partition/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Set/Partition.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/Partition/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/Partition
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set
+@dirrmtry %%SITE_PERL%%/Set