aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Statistics-Descriptive-Discrete
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-12-15 23:23:22 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-12-15 23:23:22 +0000
commit78c704ae27e7e81ab8f0c6388898c076f12637e0 (patch)
tree9bfd35588bd007fea0127d200716d03b0cd3b487 /math/p5-Statistics-Descriptive-Discrete
parent66b5c1f0a5f7431ea39c0d4cfd763c8e7a9a880e (diff)
downloadports-78c704ae27e7e81ab8f0c6388898c076f12637e0.tar.gz
ports-78c704ae27e7e81ab8f0c6388898c076f12637e0.zip
Adding port math/p5-Statistics-Descriptive-Discrete, Compute descriptive
statistics for discrete data sets. Submitted by: aaron
Notes
Notes: svn path=/head/; revision=179882
Diffstat (limited to 'math/p5-Statistics-Descriptive-Discrete')
-rw-r--r--math/p5-Statistics-Descriptive-Discrete/Makefile34
-rw-r--r--math/p5-Statistics-Descriptive-Discrete/distinfo3
-rw-r--r--math/p5-Statistics-Descriptive-Discrete/pkg-descr21
-rw-r--r--math/p5-Statistics-Descriptive-Discrete/pkg-plist11
4 files changed, 69 insertions, 0 deletions
diff --git a/math/p5-Statistics-Descriptive-Discrete/Makefile b/math/p5-Statistics-Descriptive-Discrete/Makefile
new file mode 100644
index 000000000000..6456d9e0d313
--- /dev/null
+++ b/math/p5-Statistics-Descriptive-Discrete/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Statistics-Descriptive-Discrete
+# Date created: 15 Dec 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Descriptive-Discrete
+PORTVERSION= 0.07
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Compute descriptive statistics for discrete data sets
+
+MAN3= Statistics::Descriptive::Discrete.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+#IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+#post-patch:
+# @${PERL} -pi -e 's/our ([^ ]+)/use vars qw($$1); $$1/g;' \
+# -e '$$_ = "" if /use warnings/;' \
+# ${WRKSRC}/lib/GraphViz/Traverse.pm \
+# ${WRKSRC}/t/*.t \
+# ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Statistics-Descriptive-Discrete/distinfo b/math/p5-Statistics-Descriptive-Discrete/distinfo
new file mode 100644
index 000000000000..c690aa30d8e5
--- /dev/null
+++ b/math/p5-Statistics-Descriptive-Discrete/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-Descriptive-Discrete-0.07.tar.gz) = 47a386239642fc75d5641bb9f213ea62
+SHA256 (Statistics-Descriptive-Discrete-0.07.tar.gz) = 9810cbb96cc03191c4bde50b609d497edaed2acd02867cb8b384f198c6d6d0ee
+SIZE (Statistics-Descriptive-Discrete-0.07.tar.gz) = 6889
diff --git a/math/p5-Statistics-Descriptive-Discrete/pkg-descr b/math/p5-Statistics-Descriptive-Discrete/pkg-descr
new file mode 100644
index 000000000000..f35c88ab4688
--- /dev/null
+++ b/math/p5-Statistics-Descriptive-Discrete/pkg-descr
@@ -0,0 +1,21 @@
+This module provides basic functions used in descriptive statistics. It
+borrows very heavily from Statistics::Descriptive::Full (which is included
+with Statistics::Descriptive) with one major difference. This module is
+optimized for discretized data e.g. data from an A/D conversion that has a
+discrete set of possible values. E.g. if your data is produced by an 8 bit
+A/D then you'd have only 256 possible values in your data set. Even though
+you might have a million data points, you'd only have 256 different values
+in those million points. Instead of storing the entire data set as
+Statistics::Descriptive does, this module only stores the values it's seen
+and the number of times it's seen each value.
+
+For very large data sets, this storage method results in significant speed
+and memory improvements. In a test case with 2.6 million data points from
+a real world application, Statistics::Descriptive::Discrete took 40
+seconds to calculate a set of statistics instead of the 561 seconds
+required by Statistics::Descriptive::Full. It also required only 4MB of
+RAM instead of the 400MB used by Statistics::Descriptive::Full for the
+same data set.
+
+WWW: http://search.cpan.org/dist/Statistics-Descriptive-Discrete
+Author: Rhet Turnbull <rhettbull@hotmail.com>
diff --git a/math/p5-Statistics-Descriptive-Discrete/pkg-plist b/math/p5-Statistics-Descriptive-Discrete/pkg-plist
new file mode 100644
index 000000000000..341824565864
--- /dev/null
+++ b/math/p5-Statistics-Descriptive-Discrete/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Statistics/Descriptive/Discrete.pm
+%%SITE_PERL%%/auto/Statistics/Descriptive/Discrete/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Descriptive/Discrete/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Descriptive/Discrete
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Descriptive
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics
+@dirrm %%SITE_PERL%%/auto/Statistics/Descriptive/Discrete
+@dirrmtry %%SITE_PERL%%/auto/Statistics/Descriptive
+@dirrmtry %%SITE_PERL%%/auto/Statistics
+@dirrmtry %%SITE_PERL%%/Statistics/Descriptive
+@dirrmtry %%SITE_PERL%%/Statistics