aboutsummaryrefslogtreecommitdiff
path: root/math/perlinnoise
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-29 23:51:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-30 02:35:54 +0000
commit1f8ca33aa5dd58be701ca81a68cf8b8e65c64dcf (patch)
treed04d04106760b8486e6e80fd8226b31c3d546f70 /math/perlinnoise
parentb38494572cdb139231d91bb1a13020b72dc70cb7 (diff)
downloadports-1f8ca33aa5dd58be701ca81a68cf8b8e65c64dcf.tar.gz
ports-1f8ca33aa5dd58be701ca81a68cf8b8e65c64dcf.zip
Diffstat (limited to 'math/perlinnoise')
-rw-r--r--math/perlinnoise/Makefile25
-rw-r--r--math/perlinnoise/distinfo3
-rw-r--r--math/perlinnoise/pkg-descr3
3 files changed, 31 insertions, 0 deletions
diff --git a/math/perlinnoise/Makefile b/math/perlinnoise/Makefile
new file mode 100644
index 000000000000..170b795aaf5c
--- /dev/null
+++ b/math/perlinnoise/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= perlinnoise
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.0.0
+CATEGORIES= math devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Header-only Perlin noise library for modern C++
+WWW= https://github.com/Reputeless/PerlinNoise
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= Reputeless
+GH_PROJECT= PerlinNoise
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/PerlinNoise.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/PerlinNoise.hpp ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/perlinnoise/distinfo b/math/perlinnoise/distinfo
new file mode 100644
index 000000000000..2620e712fd2d
--- /dev/null
+++ b/math/perlinnoise/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688082287
+SHA256 (Reputeless-PerlinNoise-v3.0.0_GH0.tar.gz) = 1fea1e7ebeb3c66b79d60c2c398aa83ccfadcef343bd396c0f0a684380e827fc
+SIZE (Reputeless-PerlinNoise-v3.0.0_GH0.tar.gz) = 331762
diff --git a/math/perlinnoise/pkg-descr b/math/perlinnoise/pkg-descr
new file mode 100644
index 000000000000..e715af25398d
--- /dev/null
+++ b/math/perlinnoise/pkg-descr
@@ -0,0 +1,3 @@
+siv::PerlinNoise is a header-only Perlin noise library for modern C++
+(C++17/20).
+The implementation is based on Ken Perlin's Improved Noise Java class.