aboutsummaryrefslogtreecommitdiff
path: root/math/physcalc
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-06-13 12:22:48 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-06-13 12:22:48 +0000
commit76867fceaa842bc8dba74aacd9ca773536274be5 (patch)
treead65ab15e011b8a5f3038dd9a98ae333d6726329 /math/physcalc
parent1b569086e7a8bc22be12b570884d79fcd0a69d11 (diff)
downloadports-76867fceaa842bc8dba74aacd9ca773536274be5.tar.gz
ports-76867fceaa842bc8dba74aacd9ca773536274be5.zip
. fix build with clang (CFLAGS+=-Wno-return-type);
. trim Makefile headers.
Notes
Notes: svn path=/head/; revision=320791
Diffstat (limited to 'math/physcalc')
-rw-r--r--math/physcalc/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/math/physcalc/Makefile b/math/physcalc/Makefile
index 946e6c0c02c6..5d2fb87b614d 100644
--- a/math/physcalc/Makefile
+++ b/math/physcalc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: physcalc
-# Date created: Sun 27 Aug 2000
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= physcalc
PORTVERSION= 2.4
@@ -24,6 +20,7 @@ USE_ZIP= yes
DEFS= -DSHAREDIR="\"${PREFIX}/share/physcalc/\""
SRCS= physconv.c physmain.c physmlib.c physnode.c physoper.c \
physsolv.c
+CFLAGS+= -Wno-return-type
pre-build:
${REINPLACE_CMD} -e "s@void main@int main@g" ${WRKSRC}/physmain.c