aboutsummaryrefslogtreecommitdiff
path: root/math/picosat
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-25 11:10:03 +0000
commit19094cd53d0b198fa023c5c3d8adabf03e623a01 (patch)
tree6898effce91a7f174db4ff6ce39990f3074fd3a3 /math/picosat
parentf24c8dd211cc3b2f69ac486c7f4f63f9f5e5fbb0 (diff)
downloadports-19094cd53d0b198fa023c5c3d8adabf03e623a01.tar.gz
ports-19094cd53d0b198fa023c5c3d8adabf03e623a01.zip
Move picosat and py-pycosat from devel -> math
- Remove from devel/Makefile - Add to math/Makefile - Update CATEGORIES for both ports - Add MOVED entries While I'm here, sort MOVED entries causing MOVEDlint.awk error [1] after r365599 [2] [1] 6470: date going backwards from 2014-08-20 to 2014-08-15 [2] https://svnweb.freebsd.org/changeset/ports/365599 Suggested by: vsevolod
Notes
Notes: svn path=/head/; revision=366063
Diffstat (limited to 'math/picosat')
-rw-r--r--math/picosat/Makefile30
-rw-r--r--math/picosat/distinfo2
-rw-r--r--math/picosat/pkg-descr10
-rw-r--r--math/picosat/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/math/picosat/Makefile b/math/picosat/Makefile
new file mode 100644
index 000000000000..a5b862479dfd
--- /dev/null
+++ b/math/picosat/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= picosat
+DISTVERSION= 957
+CATEGORIES= math
+MASTER_SITES= http://fmv.jku.at/picosat/
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Satisfiability (SAT) solver for boolean variables
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_LDCONFIG= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --shared --trace --stats
+MAKEFILE= makefile
+MAKE_JOBS_UNSAFE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/picosat ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomcs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picomus ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/picogcnf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_LIB} ${WRKSRC}/libpicosat.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libpicosat.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/picosat.h ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>
diff --git a/math/picosat/distinfo b/math/picosat/distinfo
new file mode 100644
index 000000000000..cfa08da26d36
--- /dev/null
+++ b/math/picosat/distinfo
@@ -0,0 +1,2 @@
+SHA256 (picosat-957.tar.gz) = 7efa0149f297971328324b90cee349223e3c9c9aab6f6e306caae2553a169822
+SIZE (picosat-957.tar.gz) = 63329
diff --git a/math/picosat/pkg-descr b/math/picosat/pkg-descr
new file mode 100644
index 000000000000..4b53b22143b8
--- /dev/null
+++ b/math/picosat/pkg-descr
@@ -0,0 +1,10 @@
+PicoSAT is a satisfiability (SAT) solver for boolean variables in
+boolean expressions. A SAT solver can determine if it is possible to
+find assignments to boolean variables that would make a given set of
+expressions true. If it's satisfiable, it can also show a set of
+assignments that make the expression true.
+
+Many problems can be broken down into a large SAT problem (perhaps with
+thousands of variables), so SAT solvers have a variety of uses.
+
+WWW: http://fmv.jku.at/picosat
diff --git a/math/picosat/pkg-plist b/math/picosat/pkg-plist
new file mode 100644
index 000000000000..75683008eba2
--- /dev/null
+++ b/math/picosat/pkg-plist
@@ -0,0 +1,7 @@
+bin/picogcnf
+bin/picomcs
+bin/picomus
+bin/picosat
+include/picosat.h
+lib/libpicosat.a
+lib/libpicosat.so