aboutsummaryrefslogtreecommitdiff
path: root/math/planarity
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2020-03-30 15:27:19 +0000
committerThierry Thomas <thierry@FreeBSD.org>2020-03-30 15:27:19 +0000
commitccf271ff1ccbe18b045ccf93bbc2332f4bc0ea96 (patch)
tree62ca828112f9336acaeaa08b9098d32c4b06e749 /math/planarity
parent2abc339cf09054a3d3b2e5bd820755df09f1cdb4 (diff)
downloadports-ccf271ff1ccbe18b045ccf93bbc2332f4bc0ea96.tar.gz
ports-ccf271ff1ccbe18b045ccf93bbc2332f4bc0ea96.zip
Adding planarity, the Edge Addition Planarity Suite, to be used by SageMath.
Notes
Notes: svn path=/head/; revision=529897
Diffstat (limited to 'math/planarity')
-rw-r--r--math/planarity/Makefile24
-rw-r--r--math/planarity/distinfo3
-rw-r--r--math/planarity/pkg-descr9
-rw-r--r--math/planarity/pkg-plist24
4 files changed, 60 insertions, 0 deletions
diff --git a/math/planarity/Makefile b/math/planarity/Makefile
new file mode 100644
index 000000000000..08f17d994cd1
--- /dev/null
+++ b/math/planarity/Makefile
@@ -0,0 +1,24 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= planarity
+PORTVERSION= 3.0.0.5
+DISTVERSIONPREFIX= Version_
+CATEGORIES= math
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Edge Addition Planarity Suite
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+
+USE_GITHUB= yes
+GH_ACCOUNT= graph-algorithms
+GH_PROJECT= edge-addition-planarity-suite
+
+USES= autoreconf libtool
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/math/planarity/distinfo b/math/planarity/distinfo
new file mode 100644
index 000000000000..48afd83aaf67
--- /dev/null
+++ b/math/planarity/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585576072
+SHA256 (graph-algorithms-edge-addition-planarity-suite-Version_3.0.0.5_GH0.tar.gz) = a019eedf67087bba1996c8b9ad47a6f1cda166c2d8976f13bfcff5c0d23e5578
+SIZE (graph-algorithms-edge-addition-planarity-suite-Version_3.0.0.5_GH0.tar.gz) = 164344
diff --git a/math/planarity/pkg-descr b/math/planarity/pkg-descr
new file mode 100644
index 000000000000..a6684c2cff08
--- /dev/null
+++ b/math/planarity/pkg-descr
@@ -0,0 +1,9 @@
+This code project provides a library for implementing graph algorithms as well
+as implementations of several planarity-related graph algorithms. The origin of
+this project is the reference implementation for the Edge Addition Planarity
+Algorithm, which is now the fastest and simplest linear-time method for
+planar graph embedding and planarity obstruction isolation (i.e. Kuratowski
+subgraph isolation).
+
+WWW: http://dx.doi.org/10.7155/jgaa.00091
+WWW: https://github.com/graph-algorithms/edge-addition-planarity-suite/
diff --git a/math/planarity/pkg-plist b/math/planarity/pkg-plist
new file mode 100644
index 000000000000..1708bc21c053
--- /dev/null
+++ b/math/planarity/pkg-plist
@@ -0,0 +1,24 @@
+bin/planarity
+include/planarity/appconst.h
+include/planarity/graph.h
+include/planarity/graphDrawPlanar.h
+include/planarity/graphDrawPlanar.private.h
+include/planarity/graphExtensions.h
+include/planarity/graphExtensions.private.h
+include/planarity/graphFunctionTable.h
+include/planarity/graphK23Search.h
+include/planarity/graphK23Search.private.h
+include/planarity/graphK33Search.h
+include/planarity/graphK33Search.private.h
+include/planarity/graphK4Search.h
+include/planarity/graphK4Search.private.h
+include/planarity/graphStructures.h
+include/planarity/listcoll.h
+include/planarity/planarity.h
+include/planarity/platformTime.h
+include/planarity/stack.h
+lib/libplanarity.a
+lib/libplanarity.so
+lib/libplanarity.so.0
+lib/libplanarity.so.0.0.0
+man/man1/planarity.1.gz