aboutsummaryrefslogtreecommitdiff
path: root/math/ploticus
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2008-09-02 22:14:43 +0000
committerMark Linimon <linimon@FreeBSD.org>2008-09-02 22:14:43 +0000
commit04ca400c9039b19c0dedacd26c19d7e59c4cc61a (patch)
tree53f0ba29adfda499bc43083f501660b35c63731b /math/ploticus
parentbd031c197181b1a2b00a63d3d7087a3d70ac2da4 (diff)
downloadports-04ca400c9039b19c0dedacd26c19d7e59c4cc61a.tar.gz
ports-04ca400c9039b19c0dedacd26c19d7e59c4cc61a.zip
Update to 2.40. Major changes:
- added: proc catlines; proc tree; proc image. - deprecated: server-side image maps (use client-side instead); definition of categories within proc areadef (use proc categories instead); proc print. - discontinued attributes: proc processdata's stack; proc usedata's element, proc getdata's rotate, and proc defineunits (use the $changeunits() function instead). - proc rangebar has been renamed proc boxplot and there are major functionality changes. Any script that uses proc rangebar will need maintenance. - rewrite of parser. - many bugfixes. For complete list, see http://ploticus.sourceforge.net/doc/news.html.
Notes
Notes: svn path=/head/; revision=219695
Diffstat (limited to 'math/ploticus')
-rw-r--r--math/ploticus/Makefile7
-rw-r--r--math/ploticus/distinfo6
-rw-r--r--math/ploticus/files/patch-README11
-rw-r--r--math/ploticus/files/patch-man-man3-libploticus.335
-rw-r--r--math/ploticus/files/patch-man_man1-pl.128
-rw-r--r--math/ploticus/files/patch-pltestsuite-README11
-rw-r--r--math/ploticus/files/patch-pltestsuite-run_all_scripts8
-rw-r--r--math/ploticus/files/patch-pltestsuite-run_script_test10
-rw-r--r--math/ploticus/files/patch-src-execline.c11
-rw-r--r--math/ploticus/files/patch-src-pl.c29
-rw-r--r--math/ploticus/files/patch-src-preliminaries.c11
-rw-r--r--math/ploticus/pkg-descr3
-rw-r--r--math/ploticus/pkg-plist18
13 files changed, 172 insertions, 16 deletions
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index df62e01de484..6d0fc21ef1c1 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= ploticus
-PORTVERSION= 2.33
-PORTREVISION= 1
+PORTVERSION= 2.40
CATEGORIES= math
MASTER_SITES= SF
DISTNAME= pl${PORTVERSION:S/.//}src
@@ -52,7 +51,7 @@ MANCOMPRESSED= no
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' \
- ${BUILD_WRKSRC}/Makefile ${BUILD_WRKSRC}/Makefile_api
+ ${BUILD_WRKSRC}/Makefile ${BUILD_WRKSRC}/mkapi
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/pl ${PREFIX}/bin/ploticus
@@ -68,7 +67,7 @@ do-install:
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/pltestsuite && ${FIND} . | \
+ cd ${WRKSRC}/pltestsuite && ${FIND} . \! -name "*.orig" | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
diff --git a/math/ploticus/distinfo b/math/ploticus/distinfo
index 58991e062933..bb71675507ef 100644
--- a/math/ploticus/distinfo
+++ b/math/ploticus/distinfo
@@ -1,3 +1,3 @@
-MD5 (pl233src.tar.gz) = 1e242200e7e52f7a24041c95f58f2fc1
-SHA256 (pl233src.tar.gz) = 020b1dd3126c591a90dc89e94dde6598c59a524fd0571b40ee384f323a35ca53
-SIZE (pl233src.tar.gz) = 467168
+MD5 (pl240src.tar.gz) = 560bf4ede9d7a132261ba36574434962
+SHA256 (pl240src.tar.gz) = 8867cb8e6c27938d6595fcbe5861ca65782ff08693de2c5bbc59aaeeaabe97bf
+SIZE (pl240src.tar.gz) = 500756
diff --git a/math/ploticus/files/patch-README b/math/ploticus/files/patch-README
new file mode 100644
index 000000000000..dcf2f7696dff
--- /dev/null
+++ b/math/ploticus/files/patch-README
@@ -0,0 +1,11 @@
+--- README.orig 2008-09-03 00:34:13.000000000 -0500
++++ README 2008-09-03 00:34:24.000000000 -0500
+@@ -6,7 +6,7 @@
+
+ For overview & complete documentation: http://ploticus.sourceforge.net
+
+-To build pl executable or libploticus, configure the 3 settings in the Makefile,
++To build ploticus executable or libploticus, configure the 3 settings in the Makefile,
+ then type:
+
+ make clean
diff --git a/math/ploticus/files/patch-man-man3-libploticus.3 b/math/ploticus/files/patch-man-man3-libploticus.3
new file mode 100644
index 000000000000..e79857127982
--- /dev/null
+++ b/math/ploticus/files/patch-man-man3-libploticus.3
@@ -0,0 +1,35 @@
+--- man/man3/libploticus.3.orig 2008-09-03 00:36:32.000000000 -0500
++++ man/man3/libploticus.3 2008-09-03 00:38:04.000000000 -0500
+@@ -38,9 +38,9 @@
+ This simple C language API
+ has all of the funcionality of the
+ .ig >>
+-<a href="pl.1.html">
++<a href="ploticus.1.html">
+ .>>
+-\0pl program
++\0ploticus program
+ .ig >>
+ </a>
+ .>>
+@@ -86,7 +86,7 @@
+ \0 stat = ploticus_init( "png", "hello.png" );
+ \0 stat += ploticus_arg( "-scale", "0.8" );
+ \0 if( stat != 0 ) {
+- \0 printf( "error in pl setup\\n" );
++ \0 printf( "error in ploticus setup\\n" );
+ \0 exit(1);
+ \0 }
+ \0 strcpy( sln, "#proc annotate" ); ploticus_execline( sln );
+@@ -149,9 +149,9 @@
+ .IP \0
+ Specify a
+ .ig >>
+-<a href="pl.1.html#options">
++<a href="ploticus.1.html#options">
+ .>>
+-\0pl command line argument.
++\0ploticus command line argument.
+ .ig >>
+ </a>
+ .>>
diff --git a/math/ploticus/files/patch-man_man1-pl.1 b/math/ploticus/files/patch-man_man1-pl.1
index 21ca7f95093d..5eee188e8ea9 100644
--- a/math/ploticus/files/patch-man_man1-pl.1
+++ b/math/ploticus/files/patch-man_man1-pl.1
@@ -1,5 +1,5 @@
---- man/man1/pl.1.orig Tue Sep 11 15:11:01 2007
-+++ man/man1/pl.1 Tue Sep 11 15:07:13 2007
+--- man/man1/pl.1.orig 2008-01-15 13:06:28.000000000 -0600
++++ man/man1/pl.1 2008-09-03 00:19:50.000000000 -0500
@@ -12,7 +12,7 @@
H4 { font-size: small; font-family: arial,helvetica,sans-serif; }
-->
@@ -22,8 +22,8 @@
<br>
.>>
--.TH pl(1) PL "02-JUN-2006 PL ploticus.sourceforge.net"
-+.TH ploticus(1) PL "02-JUN-2006 PL ploticus.sourceforge.net"
+-.TH pl(1) PL "15-JAN-2008 PL ploticus.sourceforge.net"
++.TH ploticus(1) "15-JAN-2008 PL ploticus.sourceforge.net"
.SH Name
-pl
@@ -49,6 +49,15 @@
.ig >>
<a href="http://ploticus.sourceforge.net">
.>>
+@@ -92,7 +92,7 @@
+ </a>
+ .>>
+ .LP
+-\fBpl\fR is a program that produces plots and charts from data, and
++\fBploticus\fR is a program that produces plots and charts from data, and
+ produces results that can be viewed on web pages, paper, slides,
+ or interactively on the screen. Standard types of plots may be
+ done using
@@ -112,7 +112,7 @@
</a>
.>>
@@ -73,7 +82,7 @@
.ig >>
&nbsp; &nbsp;
.>>
-@@ -1266,32 +1266,32 @@
+@@ -1289,32 +1289,32 @@
</a>
.>>
.IP \0
@@ -116,3 +125,12 @@
and view using ghostview.
.ig >>
+@@ -1362,7 +1362,7 @@
+ \fBLC_CTYPE\fR, \fBLC_COLLATE\fR, \fBLANG\fR
+ .IP \0
+ Locale support. Thanks to Oleg Bartunov oleg@sai.msu.su
+-for contributing this. \fBpl\fR must be
++for contributing this. \fBploticus\fR must be
+ built with -DLOCALE for this to work.
+
+
diff --git a/math/ploticus/files/patch-pltestsuite-README b/math/ploticus/files/patch-pltestsuite-README
new file mode 100644
index 000000000000..c59c76556bbc
--- /dev/null
+++ b/math/ploticus/files/patch-pltestsuite-README
@@ -0,0 +1,11 @@
+--- pltestsuite/README.orig 2008-09-03 00:40:49.000000000 -0500
++++ pltestsuite/README 2008-09-03 00:41:02.000000000 -0500
+@@ -1,7 +1,7 @@
+ This directory contains a set of script examples as well as scripts to
+ run prefab examples.
+
+-It is assumed that pl (pl.exe on win32) is in your command PATH or else
++It is assumed that the ploticus binary is in your command PATH or else
+ copied into this directory.
+
+
diff --git a/math/ploticus/files/patch-pltestsuite-run_all_scripts b/math/ploticus/files/patch-pltestsuite-run_all_scripts
new file mode 100644
index 000000000000..8edfe2d590f6
--- /dev/null
+++ b/math/ploticus/files/patch-pltestsuite-run_all_scripts
@@ -0,0 +1,8 @@
++++ pltestsuite/run_all_scripts.orig 2008-09-03 00:45:57.000000000 -0500
+--- pltestsuite/run_all_scripts 2008-09-03 00:46:11.000000000 -0500
+@@ -1,3 +1,3 @@
+ DEV=
+-echo "bigcsv.pl ----"; pl bigcsv.pl $DEV
+-echo "windbarbs.pl ----"; pl windbarbs.pl $DEV
++echo "bigcsv.pl ----"; ploticus bigcsv.pl $DEV
++echo "windbarbs.pl ----"; ploticus windbarbs.pl $DEV
diff --git a/math/ploticus/files/patch-pltestsuite-run_script_test b/math/ploticus/files/patch-pltestsuite-run_script_test
new file mode 100644
index 000000000000..a7ccc4b6a69f
--- /dev/null
+++ b/math/ploticus/files/patch-pltestsuite-run_script_test
@@ -0,0 +1,10 @@
++++ pltestsuite/run_script_test.orig 2008-09-03 00:46:11.000000000 -0500
+--- pltestsuite/run_script_test 2008-09-03 00:46:24.000000000 -0500
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ #
+-PL="pl"
++PL="ploticus"
+ echo "You will be invoking this instance of ploticus:"
+ which $PL
+
diff --git a/math/ploticus/files/patch-src-execline.c b/math/ploticus/files/patch-src-execline.c
new file mode 100644
index 000000000000..f550f7a16cf8
--- /dev/null
+++ b/math/ploticus/files/patch-src-execline.c
@@ -0,0 +1,11 @@
+--- src/execline.c.orig 2008-09-03 00:52:18.000000000 -0500
++++ src/execline.c 2008-09-03 00:53:46.000000000 -0500
+@@ -352,7 +352,7 @@
+ if( PLS.eready ) Eflush();
+ n = report_convmsgcount();
+ if( PLS.debug && n > 0 ) {
+- fprintf( PLS.diagfp, "note: pl proc %s encountered %d unplottable data values\n", procname, n );
++ fprintf( PLS.diagfp, "note: ploticus proc %s encountered %d unplottable data values\n", procname, n );
+ zero_convmsgcount();
+ }
+ return( stat );
diff --git a/math/ploticus/files/patch-src-pl.c b/math/ploticus/files/patch-src-pl.c
new file mode 100644
index 000000000000..a5a436a71b5e
--- /dev/null
+++ b/math/ploticus/files/patch-src-pl.c
@@ -0,0 +1,29 @@
+--- src/pl.c.orig 2008-09-03 00:53:46.000000000 -0500
++++ src/pl.c 2008-09-03 00:54:16.000000000 -0500
+@@ -151,7 +151,7 @@
+
+ else if( strcmp( arg, "-f" )==0 ) {
+ if( strlen( nextarg ) > MAXPATH-10 ) { /* allow extra for output file suffix add */
+- fprintf( PLS.errfp, "pl: script file name too long" );
++ fprintf( PLS.errfp, "ploticus: script file name too long" );
+ PL_version_msg( 0 ); exit( 1 );
+ }
+ strcpy( scriptfile, nextarg );
+@@ -180,7 +180,7 @@
+ if( !found && arg[0] == '-' ) Eerr( 4892, "warning, unrecognized argument", arg );
+ else if( !found && scriptfile[0] == '\0' ) {
+ if( strlen( arg ) > MAXPATH-10 ) { /* allow extra for output file suffix add */
+- fprintf( PLS.errfp, "pl: script file name too long" );
++ fprintf( PLS.errfp, "ploticus: script file name too long" );
+ PL_version_msg( 0 ); exit( 1 );
+ }
+ strcpy( scriptfile, arg );
+@@ -228,7 +228,7 @@
+
+
+ if( scriptfile[0] == '\0' ) {
+- fprintf( PLS.diagfp, "usage: pl scriptfile [options] ...or... pl -prefab prefabname [options]\n" );
++ fprintf( PLS.diagfp, "usage: ploticus scriptfile [options] ...or... ploticus -prefab prefabname [options]\n" );
+ PL_version_msg( 0 );
+ }
+
diff --git a/math/ploticus/files/patch-src-preliminaries.c b/math/ploticus/files/patch-src-preliminaries.c
new file mode 100644
index 000000000000..6797f99b4716
--- /dev/null
+++ b/math/ploticus/files/patch-src-preliminaries.c
@@ -0,0 +1,11 @@
+--- src/preliminaries.c.orig 2008-09-03 00:54:16.000000000 -0500
++++ src/preliminaries.c 2008-09-03 00:54:38.000000000 -0500
+@@ -276,7 +276,7 @@
+ PL_init_mem();
+
+ if( PLS.debug ) {
+- fprintf( PLS.diagfp, "Version: pl %s\n", PLVERSION );
++ fprintf( PLS.diagfp, "Version: ploticus %s\n", PLVERSION );
+ if( PLS.cgiargs != NULL ) fprintf( PLS.diagfp, "operating in CGI mode\n" );
+ Epcodedebug( 1, PLS.diagfp ); /* tell pcode.c to output diagnostics too */
+ }
diff --git a/math/ploticus/pkg-descr b/math/ploticus/pkg-descr
index 393b93c4a52c..53b7875d90b1 100644
--- a/math/ploticus/pkg-descr
+++ b/math/ploticus/pkg-descr
@@ -17,4 +17,7 @@ goal is to display data crisply without extra decoration and distracting
"dingbats" that cloud the picture. Thus there is little support for 3-D
effects, gradient backgrounds, and so on.
+FreeBSD note: the binary is referred to as 'pl' in the source files, but
+is installed as 'ploticus' so as to avoid conflicts with other ports.
+
WWW: http://ploticus.sourceforge.net/
diff --git a/math/ploticus/pkg-plist b/math/ploticus/pkg-plist
index f6126de89a67..8755a1154edc 100644
--- a/math/ploticus/pkg-plist
+++ b/math/ploticus/pkg-plist
@@ -1,12 +1,16 @@
bin/ploticus
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Diag.out
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/annot
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/annot2.gif
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/annot2.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/api_examp.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bars3.htm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/clickmap_mouse.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bigcsv.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/catlines1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colorgrid.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colorgrid2.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cumufrac.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/curve1.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/data1
@@ -45,9 +49,12 @@ bin/ploticus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/distrib.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawcom.dcm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/drawcom.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtfut.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtfut.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errbar1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errbar5.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/heatmap3.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hgb.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hitcount.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hitcount3.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kmslide.htm
@@ -55,16 +62,18 @@ bin/ploticus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lineplot20.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lineplot4.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lineplot5.htm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mouse.dat
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mouse.map
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pie1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plconfig.spanish
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/propbars1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quarters.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rangesweep2_dostext.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_all_scripts
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_prefabs_test
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_prefabs_test.bat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_script_test
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_script_test.bat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sar-cpu.dat
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sar-cpu.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scatterplot10.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scatterplot10.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scatterplot4.htm
@@ -90,13 +99,14 @@ bin/ploticus
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeline2.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timely.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timely.htm
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unnamed.map
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tree1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vector1.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/venn.htm
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vermonth.tab
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vf.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wind.csv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/windbarbs.htm
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ycase.newick
%%DATADIR%%/README
%%DATADIR%%/chron.pl
%%DATADIR%%/chron.pl-