aboutsummaryrefslogtreecommitdiff
path: root/math/plplot/files
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-01-14 17:35:24 +0000
committerR. Imura <imura@FreeBSD.org>2000-01-14 17:35:24 +0000
commit5f76ca8d6b7342f050cdfe9a81d9e48dcf9c7122 (patch)
tree300f34735d3e24780b55a5aa7063f189017ba4d1 /math/plplot/files
parenta3b7d0c16a0b4bf70a7ef51aa0b3f14ce3712d50 (diff)
downloadports-5f76ca8d6b7342f050cdfe9a81d9e48dcf9c7122.tar.gz
ports-5f76ca8d6b7342f050cdfe9a81d9e48dcf9c7122.zip
Notes
Diffstat (limited to 'math/plplot/files')
-rw-r--r--math/plplot/files/patch-aa48
-rw-r--r--math/plplot/files/patch-ab62
-rw-r--r--math/plplot/files/patch-ad7
-rw-r--r--math/plplot/files/patch-ae49
-rw-r--r--math/plplot/files/patch-af11
5 files changed, 158 insertions, 19 deletions
diff --git a/math/plplot/files/patch-aa b/math/plplot/files/patch-aa
index 341419dd1e15..ff13bb319a2f 100644
--- a/math/plplot/files/patch-aa
+++ b/math/plplot/files/patch-aa
@@ -1,19 +1,34 @@
---- configure.orig Tue Jun 6 14:58:50 1995
-+++ configure Sat Sep 26 23:34:48 1998
+--- configure.orig Wed Jun 7 04:58:50 1995
++++ configure Wed Jan 5 00:15:16 2000
+@@ -1175,10 +1175,10 @@
+ # ----------------------------------------------------------------------------
+
+ if test "$with_gcc" = "yes"; then
+- CC=gcc
+- CXX=gcc
+- OCC="gcc -traditional"
+- CPP="gcc -E"
++ CC=$CC
++ CXX=$CXX
++ OCC="$CC -traditional"
++ CPP="$CC -E"
+
+ if test "$with_warn" = "yes"; then
+ SYS_FLAGS_C=-Wall
@@ -1472,13 +1472,13 @@
# ----------------------------------------------------------------------------
CC_FLAGS=\
-"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $OPT_FLAG_C"
-+"-c $CFLAGS $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $OPT_FLAG_C"
++"-c $DBL_FLAG_C $DEBUG_FLAG_C $SYS_FLAGS_C $PROF_FLAG_C $CFLAGS"
CXX_FLAGS=\
-"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $OPT_FLAG_CXX"
-+"-c $CFLAGS $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $OPT_FLAG_CXX"
++"-c $DBL_FLAG_CXX $DEBUG_FLAG_CXX $SYS_FLAGS_CXX $PROF_FLAG_CXX $CXXFLAGS"
F77_FLAGS=\
-"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $OPT_FLAG_F"
-+"-c $FFLAGS $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $OPT_FLAG_F"
++"-c $DBL_FLAG_F $DEBUG_FLAG_F $SYS_FLAGS_F $PROF_FLAG_F $FFLAGS"
LDC_FLAGS=\
"$PROF_FLAG_LC $SYS_FLAGS_LC $DEBUG_FLAG_LC"
@@ -38,7 +53,7 @@
HP-UX-* )
SO=".sl"
SHLIB_F77FLAGS="+z"
-@@ -4192,16 +4206,16 @@
+@@ -4192,16 +4206,19 @@
fi
fi
if test -z "$DOC_DIR"; then
@@ -55,6 +70,27 @@
if test -z "$DEMOS_DIR"; then
- DEMOS_DIR=$prefix/examples
+ DEMOS_DIR=$prefix/share/examples/plplot
++fi
++if test -z "$DATA_DIR"; then
++ DATA_DIR=$prefix/libdata/plplot
fi
cat >> confdefs.h <<EOF
+@@ -4216,6 +4233,9 @@
+ #define TCL_DIR "$TCL_DIR"
+ EOF
+
++cat >> confdefs.h <<EOF
++#define DATA_DIR "$DATA_DIR"
++EOF
+
+
+
+@@ -4449,6 +4469,7 @@
+ s%@INFO_DIR@%$INFO_DIR%g
+ s%@INCLUDE_DIR@%$INCLUDE_DIR%g
+ s%@DEMOS_DIR@%$DEMOS_DIR%g
++s%@DATA_DIR@%$DATA_DIR%g
+ s%@SHARED@%$SHARED%g
+
+ CEOF
diff --git a/math/plplot/files/patch-ab b/math/plplot/files/patch-ab
index 6d2d337d2583..fd8442e1158a 100644
--- a/math/plplot/files/patch-ab
+++ b/math/plplot/files/patch-ab
@@ -1,22 +1,58 @@
---- cf/install.in.orig Tue Jun 6 20:13:09 1995
-+++ cf/install.in Fri Oct 3 15:41:49 1997
-@@ -27,15 +27,15 @@
-
- install_lib:
- -if test ! -d $(INCLUDE_DIR); then mkdir -p $(INCLUDE_DIR); fi
-- -if test ! -d $(LIB_DIR); then mkdir -p $(LIB_DIR); fi
-+ -if test ! -d $(LIB_DIR)/plplot; then mkdir -p $(LIB_DIR)/plplot; fi
+--- cf/install.in.orig Wed Jun 7 03:13:09 1995
++++ cf/install.in Wed Jan 5 02:26:56 2000
+@@ -31,19 +31,18 @@
-if test ! -d $(DOC_DIR); then mkdir -p $(DOC_DIR); fi
-if test ! -d $(BIN_DIR); then mkdir -p $(BIN_DIR); fi
-if test ! -d $(INFO_DIR); then mkdir -p $(INFO_DIR); fi
- -cd $(top_srcdir)/lib; cp *.fnt *.map $(LIB_DIR)
-+ -cd $(top_srcdir)/lib; cp *.fnt *.map $(LIB_DIR)/plplot
- -cp $(PLLIB_BASE)* $(LIB_DIR); \
+- -cp $(PLLIB_BASE)* $(LIB_DIR); \
- for file in $(PLLIB_BASE)*; do $(RANLIB) $(LIB_DIR)/$$file; done
++ -if test ! -d $(DATA_DIR); then mkdir -p $(DATA_DIR); fi
++ -cd $(top_srcdir)/lib; ${BSD_INSTALL_DATA} *.fnt *.map $(DATA_DIR)
++ ${BSD_INSTALL_DATA} $(PLLIB_BASE)* $(LIB_DIR); \
+ for file in $(PLLIB_BASE)*.a; do $(RANLIB) $(LIB_DIR)/$$file; done
-cd $(top_srcdir); \
- cp README NEWS CHANGES Copyright COPYING.LIB FAQ ToDo \
-+ cp README NEWS CHANGES FAQ ToDo \
- mklinks $(DOC_DIR)
+- mklinks $(DOC_DIR)
++ ${BSD_INSTALL_DATA} README NEWS CHANGES FAQ ToDo mklinks $(DOC_DIR)
-if test ! -f $(DOC_DIR)/README.local; then \
- cp $(top_srcdir)/doc/README.local $(DOC_DIR); fi
+- cp $(top_srcdir)/doc/README.local $(DOC_DIR); fi
+- -cp $(top_srcdir)/doc/*.info $(INFO_DIR)
+- -cd $(top_srcdir)/scripts; cp pl* $(BIN_DIR)
++ ${BSD_INSTALL_DATA} $(top_srcdir)/doc/README.local $(DOC_DIR); fi
++ -cd $(top_srcdir)/scripts; ${BSD_INSTALL_SCRIPT} pl* $(BIN_DIR)
+ -cd $(top_srcdir)/include; \
+- cp plplotP.h plplot.h plxwd.h plevent.h plstrm.h pdf.h \
+- $(INCLUDE_DIR)
++ ${BSD_INSTALL_DATA} plplotP.h plplot.h plxwd.h plevent.h plstrm.h \
++ pdf.h $(INCLUDE_DIR)
+
+ install_demos:
+ -if test ! -d $(DEMOS_DIR); then mkdir -p $(DEMOS_DIR); fi
+@@ -56,11 +55,11 @@
+ -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/c
+ -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/f77
+ -$(LN) $(DEMOS_DIR)/Makefile $(DEMOS_DIR)/tk
+- -cd $(top_srcdir)/examples/c; cp * $(DEMOS_DIR)/c
+- -cd $(top_srcdir)/examples/f77; cp * $(DEMOS_DIR)/f77
+- -cd $(top_srcdir)/examples/python; cp * $(DEMOS_DIR)/python
+- -cd $(top_srcdir)/examples/tcl; cp * $(DEMOS_DIR)/tcl
+- -cd $(top_srcdir)/examples/tk; cp * $(DEMOS_DIR)/tk
++ -cd $(top_srcdir)/examples/c; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/c
++ -cd $(top_srcdir)/examples/f77; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/f77
++ -cd $(top_srcdir)/examples/python; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/python
++ -cd $(top_srcdir)/examples/tcl; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tcl
++ -cd $(top_srcdir)/examples/tk; ${BSD_INSTALL_DATA} * $(DEMOS_DIR)/tk
+ -$(LN) $(DEMOS_DIR)/tcl/x??.tcl $(DEMOS_DIR)/tk
+
+ install_utils:
+@@ -72,8 +71,7 @@
+ $(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \
+ -o pltek$E; \
+ fi
+- -strip plrender$E pltek$E
+- -cp plrender$E pltek$E $(BIN_DIR)
++ ${BSD_INSTALL_PROGRAM} plrender$E pltek$E $(BIN_DIR)
+
+ # Remember, this is bogus...
+ # $(LDC) $(LDC_FLAGS) pltek$O $(LIB_INSTALL) \
diff --git a/math/plplot/files/patch-ad b/math/plplot/files/patch-ad
new file mode 100644
index 000000000000..ddf31ae5bd22
--- /dev/null
+++ b/math/plplot/files/patch-ad
@@ -0,0 +1,7 @@
+--- cf/init.in.orig Mon May 15 16:54:21 1995
++++ cf/init.in Wed Jan 5 01:26:07 2000
+@@ -58,3 +58,4 @@
+ INCLUDE_DIR = @INCLUDE_DIR@
+ TCL_DIR = @TCL_DIR@
+ DEMOS_DIR = @DEMOS_DIR@
++DATA_DIR = @DATA_DIR@
diff --git a/math/plplot/files/patch-ae b/math/plplot/files/patch-ae
new file mode 100644
index 000000000000..b70691413dd3
--- /dev/null
+++ b/math/plplot/files/patch-ae
@@ -0,0 +1,49 @@
+--- src/plctrl.c.orig Sat May 27 05:20:57 1995
++++ src/plctrl.c Wed Jan 5 01:50:02 2000
+@@ -131,7 +131,7 @@
+ /* Anything else is assumed to be Unix */
+
+ #ifndef PLLIBDEV
+-#define PLLIBDEV "/usr/local/plplot/lib"
++#define PLLIBDEV "%%PREFIX%%/libdata/plplot"
+ #endif
+
+ #endif
+@@ -1153,7 +1153,7 @@
+ * PLPLOT_LIB_ENV = $(PLPLOT_LIB)
+ * current directory
+ * PLPLOT_HOME_ENV/lib = $(PLPLOT_HOME)/lib
+- * LIB_DIR
++ * DATA_DIR
+ * PLLIBDEV
+ \*--------------------------------------------------------------------------*/
+
+@@ -1195,12 +1195,12 @@
+
+ /**** search installed location ****/
+
+-#if defined (LIB_DIR)
+- plGetName(LIB_DIR, "", fn, &fs);
++#if defined (DATA_DIR)
++ plGetName(DATA_DIR, "", fn, &fs);
+
+ if ((file = fopen(fs, "rb")) != NULL)
+ goto done;
+-#endif /* LIB_DIR */
++#endif /* DATA_DIR */
+
+ /**** search hardwired location ****/
+
+@@ -1215,9 +1215,9 @@
+
+ pltext();
+ fprintf(stderr, "\nCannot open library file: %s\n", fn);
+-#if defined (LIB_DIR)
+- fprintf(stderr, "lib dir=\"" LIB_DIR "\"\n" ); /* what WAS set? */
+-#endif /* LIB_DIR */
++#if defined (DATA_DIR)
++ fprintf(stderr, "lib dir=\"" DATA_DIR "\"\n" ); /* what WAS set? */
++#endif /* DATA_DIR */
+ plgra();
+ return NULL;
+
diff --git a/math/plplot/files/patch-af b/math/plplot/files/patch-af
new file mode 100644
index 000000000000..3c281ffe6ccd
--- /dev/null
+++ b/math/plplot/files/patch-af
@@ -0,0 +1,11 @@
+--- utils/pltek.c.orig Fri Sep 16 12:45:46 1994
++++ utils/pltek.c Tue Jan 4 20:49:26 2000
+@@ -110,7 +110,7 @@
+ oldpage = ipage;
+ printf("Page %d/%d> ", ipage, npage);
+
+- gets(ibuf);
++ fgets(ibuf, sizeof(ibuf), stdin);
+ c = ibuf[0];
+
+ /* User input a page number or a return */