aboutsummaryrefslogtreecommitdiff
path: root/math/plplot
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-12-08 13:32:59 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-12-08 13:32:59 +0000
commita75d0d7eef385c46ab09c007c4b22fa40fdba85b (patch)
tree4aa1bcf5e8e288c4a0cebddfa3fef386b65fb233 /math/plplot
parentd41000b4b10909801e6f74700c286532b8bfb466 (diff)
downloadports-a75d0d7eef385c46ab09c007c4b22fa40fdba85b.tar.gz
ports-a75d0d7eef385c46ab09c007c4b22fa40fdba85b.zip
qhull:
- Update to 2015.2. - Install docs in DOCSDIR. - Add a workaround patch for 9.x base compiler. plplot: - Accomodate changes to qhull, including port revision bump. PR: ports/215078 Submitted by: John Hein <z7dr6ut7gs@snkmail.com>
Notes
Notes: svn path=/head/; revision=428116
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 539e1e03f4ae..d6d7e52b5dfd 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -40,8 +40,8 @@ FREEFONT_DIR= ${LOCALBASE}/share/fonts/freefont-ttf
OPTIONS_DEFINE= FORTRAN GD LUA PYTHON QT4 TCLTK THREADS WXGTK X11 DOCS
OPTIONS_RADIO= QHULL
-OPTIONS_RADIO_QHULL= QHULL2012 QHULL2003
-OPTIONS_DEFAULT= QHULL2012 THREADS X11
+OPTIONS_RADIO_QHULL= QHULL2015 QHULL2003
+OPTIONS_DEFAULT= QHULL2015 THREADS X11
OPTIONS_SUB= yes
FORTRAN_USES= fortran
@@ -64,11 +64,11 @@ PYTHON_CONFIGURE_ENV= PYTHON_VERSION="${PYTHON_VERSION}"
PYTHON_CMAKE_OFF= -DENABLE_python:BOOL=OFF
QHULL2003_DESC= Legacy Qhull support
-QHULL2012_DESC= Latest Qhull support
-QHULL2012_LIB_DEPENDS= libqhull.so.6:math/qhull
+QHULL2015_DESC= Latest Qhull support
+QHULL2015_LIB_DEPENDS= libqhull.so.7:math/qhull
QHULL2003_LIB_DEPENDS= libqhull.so.5:math/qhull5
-QHULL2012_CMAKE_ON= -DQHULL_INCLUDE_DIRS="${LOCALBASE}/include/libqhull"
-QHULL2012_2FIX= lib/nn/delaunay.c src/plgridd.c
+QHULL2015_CMAKE_ON= -DQHULL_INCLUDE_DIRS="${LOCALBASE}/include/libqhull"
+QHULL2015_2FIX= lib/nn/delaunay.c src/plgridd.c
TCLTK_LIB_DEPENDS= libitk.so:x11-toolkits/itk
TCLTK_RUN_DEPENDS= iwidgets>0:x11-toolkits/iwidgets
@@ -114,8 +114,8 @@ pre-configure:
${WRKSRC}/cmake/modules/FindLTDL.cmake
${GREP} -lR "/usr/local" ${WRKSRC}/cmake/modules | ${XARGS} \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
-.if ${PORT_OPTIONS:MQHULL2012}
-. for src in ${QHULL2012_2FIX}
+.if ${PORT_OPTIONS:MQHULL2015}
+. for src in ${QHULL2015_2FIX}
${REINPLACE_CMD} -e 's|qhull/qhull_a|libqhull/qhull_a|' \
${WRKSRC}/${src}
. endfor