aboutsummaryrefslogtreecommitdiff
path: root/math/polymake/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-05-04 14:06:08 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-05-04 14:06:08 +0000
commit63f76304d6f21c191cb8e08ab49787bcf031fb6d (patch)
tree20dbde6d95ce50dde89bcaeaaee0c6c3ee84e6b1 /math/polymake/Makefile
parent72e61e01d5850e4a1b7f817ff8c3f51d32dc101c (diff)
downloadports-63f76304d6f21c191cb8e08ab49787bcf031fb6d.tar.gz
ports-63f76304d6f21c191cb8e08ab49787bcf031fb6d.zip
Notes
Diffstat (limited to 'math/polymake/Makefile')
-rw-r--r--math/polymake/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index ccfec34013e9..cfdce3314cb8 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -53,18 +53,15 @@ USE_LDCONFIG= yes
IGNORE= does not build with Perl 5.14+
.endif
-.if !defined(DISABLE_MAKE_JOBS)
pre-fetch:
- @MAKE_JOBS_NUMBER=${MAKE_JOBS_NUMBER}; \
- if [ $${MAKE_JOBS_NUMBER} -gt 1 ]; then \
+ @if [ ${MAKE_JOBS_NUMBER} -gt 1 ]; then \
${ECHO_CMD} "Building this port uses a lot of CPU power, and a lot of memory to the point"; \
${ECHO_CMD} "that swap space might be used extensively. Consider using less threads, as"; \
${ECHO_CMD} "this might cause the build to be considerably faster. Currently the build is"; \
- ${ECHO_CMD} "set to use $${MAKE_JOBS_NUMBER} threads. To change to <n> threads, use"; \
+ ${ECHO_CMD} "set to use ${MAKE_JOBS_NUMBER} threads. To change to <n> threads, use"; \
${ECHO_CMD}; \
${ECHO_CMD} "make MAKE_JOBS_NUMBER=<n>"; \
fi
-.endif
post-install:
${INSTALL_DATA} ${PREFIX}/libexec/polymake/conf.make ${PREFIX}/libexec/polymake/conf.make.in