aboutsummaryrefslogtreecommitdiff
path: root/math/primegen
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 15:09:30 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-15 15:09:30 +0000
commit9ee40d8837d3c649d69331734b55be735c82ed30 (patch)
tree11c4104ba5fc75aa3605f2666afc4174bbb151a2 /math/primegen
parent373a453fc67be58e76a5b1e72d09c2cd0f8d3f37 (diff)
downloadports-9ee40d8837d3c649d69331734b55be735c82ed30.tar.gz
ports-9ee40d8837d3c649d69331734b55be735c82ed30.zip
- Add stage support
- Improve COMMENT
Notes
Notes: svn path=/head/; revision=344402
Diffstat (limited to 'math/primegen')
-rw-r--r--math/primegen/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/math/primegen/Makefile b/math/primegen/Makefile
index b2a98457fade..8405f4e0ad3e 100644
--- a/math/primegen/Makefile
+++ b/math/primegen/Makefile
@@ -7,13 +7,10 @@ CATEGORIES= math
MASTER_SITES= http://cr.yp.to/primegen/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A small, fast library to generate prime numbers in order
+COMMENT= Small, fast library to generate prime numbers in order
ALL_TARGET=
-MAN1= primes.1 primegaps.1
-MAN3= primegen.3
-
PROGRAM_FILES= primes primegaps
HEADER_FILES= primegen.h
LIB_FILES= libprimegen.a
@@ -27,7 +24,10 @@ PLIST_FILES+= ${HEADER_FILES:S,^,include/,}
# libraries
PLIST_FILES+= ${LIB_FILES:S,^,lib/,}
-NO_STAGE= yes
+# man pages
+PLIST_FILES+= man/man1/primes.1.gz man/man1/primegaps.1.gz \
+ man/man3/primegen.3.gz
+
post-patch:
@${FIND} ${WRKSRC} -type f -exec \
${REINPLACE_CMD} -E -e 's!(primegen.a)!lib\1!' {} \;
@@ -39,19 +39,16 @@ do-configure:
do-install:
.for file in ${PROGRAM_FILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
.for file in ${HEADER_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/include
.endfor
.for file in ${LIB_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib
-.endfor
-.for file in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/${file} ${MAN1PREFIX}/man/man1
-.endfor
-.for file in ${MAN3}
- @${INSTALL_MAN} ${WRKSRC}/${file} ${MAN3PREFIX}/man/man3
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/lib
.endfor
+ @${INSTALL_MAN} ${WRKSRC}/primes.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/primegaps.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/primegen.3 ${STAGEDIR}${MAN3PREFIX}/man/man3
.include <bsd.port.mk>