aboutsummaryrefslogtreecommitdiff
path: root/math/primme
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-05-16 18:03:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-05-16 18:03:14 +0000
commit9f9264b37474bd85f1a87547a7175a2adf882387 (patch)
tree0022b5e71d3493c54e69259a49bbd6305d967f6c /math/primme
parent0993e0e497b184e5fae4dd0d81144e3949c68f8c (diff)
Notes
Diffstat (limited to 'math/primme')
-rw-r--r--math/primme/Makefile5
-rw-r--r--math/primme/distinfo6
-rw-r--r--math/primme/files/patch-examples_Makefile8
-rw-r--r--math/primme/files/patch-tests_Makefile10
4 files changed, 14 insertions, 15 deletions
diff --git a/math/primme/Makefile b/math/primme/Makefile
index 62f4445fc139..8b3df2427511 100644
--- a/math/primme/Makefile
+++ b/math/primme/Makefile
@@ -2,8 +2,7 @@
PORTNAME= primme
DISTVERSIONPREFIX= v
-DISTVERSION= 3.1
-PORTREVISION= 1
+DISTVERSION= 3.1.1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -54,6 +53,6 @@ PLIST_FILES= include/primme.h \
include/primme_svds_f90.inc \
lib/libprimme.so \
lib/libprimme.so.3 \
- lib/libprimme.so.3.0
+ lib/libprimme.so.3.1
.include <bsd.port.mk>
diff --git a/math/primme/distinfo b/math/primme/distinfo
index 3f0656a2a642..29612cdb53e3 100644
--- a/math/primme/distinfo
+++ b/math/primme/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588489073
-SHA256 (primme-primme-v3.1_GH0.tar.gz) = 6ce474777270402e39bde78c26203ac185ef0c005090ed527790eea25360b0a7
-SIZE (primme-primme-v3.1_GH0.tar.gz) = 13119912
+TIMESTAMP = 1589651424
+SHA256 (primme-primme-v3.1.1_GH0.tar.gz) = 295891862b8e379c79d99bf5029e7de317888c9b01c98d206f9043878dd5df25
+SIZE (primme-primme-v3.1.1_GH0.tar.gz) = 13120437
diff --git a/math/primme/files/patch-examples_Makefile b/math/primme/files/patch-examples_Makefile
index e3b18cd23de1..a5ad8f5c25ef 100644
--- a/math/primme/files/patch-examples_Makefile
+++ b/math/primme/files/patch-examples_Makefile
@@ -1,11 +1,11 @@
---- examples/Makefile.orig 2018-10-28 03:29:33 UTC
+--- examples/Makefile.orig 2020-05-04 01:52:54 UTC
+++ examples/Makefile
@@ -8,7 +8,7 @@ include ../Link_flags
- override INCLUDE += -I../include
- override FINCLUDE += -I../include
+ INCLUDE := -I../include
+ FINCLUDE := -I../include
-LIBS := ../lib/libprimme.a $(LIBS)
+LIBS := ../lib/libprimme.so $(LIBS)
- EXAMPLES_C = ex_eigs_dseq ex_eigs_zseq ex_svds_dseq ex_svds_zseq
+ EXAMPLES_C = ex_eigs_dseq ex_eigs_zseq ex_eigs_zseq_normal ex_svds_dseq ex_svds_zseq
EXAMPLES_CXX = ex_eigs_zseqxx ex_svds_zseqxx
diff --git a/math/primme/files/patch-tests_Makefile b/math/primme/files/patch-tests_Makefile
index 3cc3f1ce5cc6..afb3719bdd44 100644
--- a/math/primme/files/patch-tests_Makefile
+++ b/math/primme/files/patch-tests_Makefile
@@ -1,15 +1,15 @@
---- tests/Makefile.orig 2018-10-28 03:25:47 UTC
+--- tests/Makefile.orig 2020-05-04 01:52:54 UTC
+++ tests/Makefile
-@@ -9,7 +9,7 @@ include ../Link_flags
- SOBJS= COMMON/shared_utils.o COMMON/ioandtest.o
+@@ -10,7 +10,7 @@ SOBJS= COMMON/shared_utils.o COMMON/ioandtest.o
COMMON_INCLUDE = -I./COMMON -I../include
- override INCLUDE += $(COMMON_INCLUDE)
+ INCLUDE := $(COMMON_INCLUDE)
+ FINCLUDE := $(COMMON_INCLUDE)
-LIBS := ../lib/libprimme.a $(LIBS)
+LIBS := ../lib/libprimme.so $(LIBS)
USE_NATIVE ?= yes
USE_PETSC ?= $(if $(findstring undefined,$(origin PETSC_DIR)),no,yes)
-@@ -89,7 +89,7 @@ all: drivers
+@@ -90,7 +90,7 @@ all: drivers
drivers: primme_double primme_doublecomplex primmesvds_double primmesvds_doublecomplex