aboutsummaryrefslogtreecommitdiff
path: root/math/prng
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-08-19 18:46:45 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-08-19 18:46:45 +0000
commit80e2755b7ffe5828a834732b67f40a5448c48f37 (patch)
treead758d834077482023af7f47b7fc98fe1ee1dc2e /math/prng
parent2eeef0b0199df4c73372f8d92fc74a3cb23bbcd7 (diff)
downloadports-80e2755b7ffe5828a834732b67f40a5448c48f37.tar.gz
ports-80e2755b7ffe5828a834732b67f40a5448c48f37.zip
enable regression tests on tinderboxes, and add a
workaround to fix builds using clang and newer gcc
Notes
Notes: svn path=/head/; revision=280030
Diffstat (limited to 'math/prng')
-rw-r--r--math/prng/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/prng/Makefile b/math/prng/Makefile
index ff56ff80fbaa..380e2ecb4235 100644
--- a/math/prng/Makefile
+++ b/math/prng/Makefile
@@ -11,6 +11,7 @@ MASTER_SITES= http://statistik.wu-wien.ac.at/software/prng/
MAINTAINER= bf@FreeBSD.org
COMMENT= Portable, high-performance ANSI-C pseudorandom number generators
+CFLAGS+= -fgnu89-inline
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
INFO= prng
@@ -32,8 +33,8 @@ post-install:
.endfor
.endif
-test: build
+check regression-test test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+ ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check)
.include <bsd.port.mk>