aboutsummaryrefslogtreecommitdiff
path: root/math/pure-rational
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-10-15 19:36:40 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-10-15 19:36:40 +0000
commita418a6d776c7d65ada6094bacfa91fb3667d7874 (patch)
treed7083372a4b8343eb456e1fa164ab1a54e1384e0 /math/pure-rational
parentd5901782d4730967fcb2d3daf3e0e57005a3e85e (diff)
downloadports-a418a6d776c7d65ada6094bacfa91fb3667d7874.tar.gz
ports-a418a6d776c7d65ada6094bacfa91fb3667d7874.zip
Notes
Diffstat (limited to 'math/pure-rational')
-rw-r--r--math/pure-rational/Makefile27
-rw-r--r--math/pure-rational/distinfo2
-rw-r--r--math/pure-rational/pkg-descr4
3 files changed, 33 insertions, 0 deletions
diff --git a/math/pure-rational/Makefile b/math/pure-rational/Makefile
new file mode 100644
index 000000000000..bf8e9f272c4b
--- /dev/null
+++ b/math/pure-rational/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pure-rational
+# Date created: 2011-10-09
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-rational
+PORTVERSION= 0.1
+CATEGORIES= math
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Rational number library for the Pure language
+
+LIB_DEPENDS+= pure:${PORTSDIR}/lang/pure
+
+LICENSE= GPLv3
+
+PLIST_FILES= lib/pure/rational.pure \
+ lib/pure/rat_interval.pure
+
+USE_GMAKE= yes
+
+MAKE_ARGS+= prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/math/pure-rational/distinfo b/math/pure-rational/distinfo
new file mode 100644
index 000000000000..c5da557efc55
--- /dev/null
+++ b/math/pure-rational/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-rational-0.1.tar.gz) = c6b52330d45cb2b79c4bbfa748d9eccb796abd3b354d3d3d663d325f4eceeb1b
+SIZE (pure-rational-0.1.tar.gz) = 44687
diff --git a/math/pure-rational/pkg-descr b/math/pure-rational/pkg-descr
new file mode 100644
index 000000000000..25a2d1bd43f1
--- /dev/null
+++ b/math/pure-rational/pkg-descr
@@ -0,0 +1,4 @@
+pure-rational provides additional operations on the rational number type
+provided by the math.pure module in the standard library.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-rational.html