aboutsummaryrefslogtreecommitdiff
path: root/math/py-GridDataFormats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-13 16:43:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-13 16:43:37 +0000
commitf1cdc0e64ded21db23978e002c9fcfa8fbd04d97 (patch)
tree112bea95cefc7775044a556022d6085ccb04a51f /math/py-GridDataFormats
parent0f62766930e8391c00023e6700d35a59469c028b (diff)
downloadports-f1cdc0e64ded21db23978e002c9fcfa8fbd04d97.tar.gz
ports-f1cdc0e64ded21db23978e002c9fcfa8fbd04d97.zip
New port: math/py-GridDataFormats: Handle data on a grid: NumPy n-dimensional arrays
Notes
Notes: svn path=/head/; revision=469805
Diffstat (limited to 'math/py-GridDataFormats')
-rw-r--r--math/py-GridDataFormats/Makefile23
-rw-r--r--math/py-GridDataFormats/distinfo3
-rw-r--r--math/py-GridDataFormats/pkg-descr5
3 files changed, 31 insertions, 0 deletions
diff --git a/math/py-GridDataFormats/Makefile b/math/py-GridDataFormats/Makefile
new file mode 100644
index 000000000000..83255b99ef29
--- /dev/null
+++ b/math/py-GridDataFormats/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= GridDataFormats
+DISTVERSION= 0.4.0
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Handle data on a grid: NumPy n-dimensional arrays
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= MDAnalysis
+USE_PYTHON= distutils autoplist concurrent
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-GridDataFormats/distinfo b/math/py-GridDataFormats/distinfo
new file mode 100644
index 000000000000..3cf87a27f11f
--- /dev/null
+++ b/math/py-GridDataFormats/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526229297
+SHA256 (MDAnalysis-GridDataFormats-0.4.0_GH0.tar.gz) = 54a6ca9e517f6fe6550c642715993f3f35d18536c1f2139fc0090d8c51964f78
+SIZE (MDAnalysis-GridDataFormats-0.4.0_GH0.tar.gz) = 291102
diff --git a/math/py-GridDataFormats/pkg-descr b/math/py-GridDataFormats/pkg-descr
new file mode 100644
index 000000000000..9de56358874c
--- /dev/null
+++ b/math/py-GridDataFormats/pkg-descr
@@ -0,0 +1,5 @@
+The GridDataFormats package provides classes to unify reading and writing
+n-dimensional datasets. One can read grid data from files, make them available
+as a Grid object, and write out the data again.
+
+WWW: https://github.com/MDAnalysis/GridDataFormats