aboutsummaryrefslogtreecommitdiff
path: root/math/py-MutatorMath/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-12-16 18:35:10 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-12-16 18:35:10 +0000
commit2e0d172440322689a0969da3af6861fee4938a29 (patch)
tree20c615b94b6a1dcef5487b5c73886df09fe41667 /math/py-MutatorMath/Makefile
parentc03756613ad75df97163376da0abaee52cb2aa7a (diff)
downloadports-2e0d172440322689a0969da3af6861fee4938a29.tar.gz
ports-2e0d172440322689a0969da3af6861fee4938a29.zip
Notes
Diffstat (limited to 'math/py-MutatorMath/Makefile')
-rw-r--r--math/py-MutatorMath/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/py-MutatorMath/Makefile b/math/py-MutatorMath/Makefile
new file mode 100644
index 000000000000..5df96c1d2392
--- /dev/null
+++ b/math/py-MutatorMath/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= MutatorMath
+PORTVERSION= 2.1.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lantw44@gmail.com
+COMMENT= Piecewise linear interpolation in multiple dimensions
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ufoLib>=2.0.0:x11-fonts/py-ufoLib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}defcon>=0.3.5:x11-fonts/py-defcon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fontMath>=0.4.4:x11-fonts/py-fontMath@${PY_FLAVOR}
+
+USES= python zip
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>