aboutsummaryrefslogtreecommitdiff
path: root/math/py-arviz/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-01 17:52:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-01 17:52:12 +0000
commitea9191355fa721062fcc514b837bddd99cbda77f (patch)
tree22cde106e7457c3db0ffdad399596c8c8eadb80a /math/py-arviz/Makefile
parent07ec3d2815d69808ca4d645a8a6c90d40f143f22 (diff)
downloadports-ea9191355fa721062fcc514b837bddd99cbda77f.tar.gz
ports-ea9191355fa721062fcc514b837bddd99cbda77f.zip
New port: math/py-arviz: Package for exploratory analysis of Bayesian models
Notes
Notes: svn path=/head/; revision=518790
Diffstat (limited to 'math/py-arviz/Makefile')
-rw-r--r--math/py-arviz/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/math/py-arviz/Makefile b/math/py-arviz/Makefile
new file mode 100644
index 000000000000..9128910867e7
--- /dev/null
+++ b/math/py-arviz/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= arviz
+DISTVERSION= 0.5.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Package for exploratory analysis of Bayesian models
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netCDF4>0:science/py-netCDF4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.23:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xarray>=0.11:devel/py-xarray@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>