aboutsummaryrefslogtreecommitdiff
path: root/math/py-bitvector
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2016-05-10 07:48:36 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2016-05-10 07:48:36 +0000
commit62a0f51378d232ec780060cbbeac75efd6d4ffe1 (patch)
treebd134172983962157d8742d4155fb1cddf7c474b /math/py-bitvector
parentf944dd7065ee260d52241c44b7a1c292970ffa20 (diff)
downloadports-62a0f51378d232ec780060cbbeac75efd6d4ffe1.tar.gz
ports-62a0f51378d232ec780060cbbeac75efd6d4ffe1.zip
Notes
Diffstat (limited to 'math/py-bitvector')
-rw-r--r--math/py-bitvector/Makefile11
-rw-r--r--math/py-bitvector/distinfo4
-rw-r--r--math/py-bitvector/pkg-descr2
3 files changed, 6 insertions, 11 deletions
diff --git a/math/py-bitvector/Makefile b/math/py-bitvector/Makefile
index 0a835d2dd58a..64c0a4cab4a6 100644
--- a/math/py-bitvector/Makefile
+++ b/math/py-bitvector/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= bitvector
-PORTVERSION= 3.1
-PORTREVISION= 1
+PORTVERSION= 3.4.4
CATEGORIES= math python
MASTER_SITES= https://engineering.purdue.edu/kak/dist/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,15 +14,11 @@ COMMENT= Pure-Python memory-efficient packed representation for bit arrays
LICENSE= PSFL
USES= python
-USE_PYTHON= distutils
+USE_PYTHON= autoplist distutils
PYDISTUTILS_PKGNAME= BitVector
PORTDOCS= README BitVector-${PORTVERSION}.html
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/BitVector.py \
- %%PYTHON_SITELIBDIR%%/BitVector.pyc \
- %%PYTHON_SITELIBDIR%%/BitVector.pyo
-
post-extract:
@${RM} -f ${WRKSRC}/test.py
@@ -31,7 +26,7 @@ DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
regression-test:
@(cd ${WRKSRC}/TestBitVector && ${PYTHON_CMD} Test.py)
diff --git a/math/py-bitvector/distinfo b/math/py-bitvector/distinfo
index 1e85334fb328..a1f70bae995a 100644
--- a/math/py-bitvector/distinfo
+++ b/math/py-bitvector/distinfo
@@ -1,2 +1,2 @@
-SHA256 (BitVector-3.1.tar.gz) = fb839af4a65b9a656d7b6aa7a83c4088023b15f2123ea3a5f8a2764a6c17b1f7
-SIZE (BitVector-3.1.tar.gz) = 157374
+SHA256 (BitVector-3.4.4.tar.gz) = e528ec6e03bcabe6d7e10d4a13459d644dd6577b73e225f7a686bd1902734186
+SIZE (BitVector-3.4.4.tar.gz) = 121822
diff --git a/math/py-bitvector/pkg-descr b/math/py-bitvector/pkg-descr
index 84d71aa1b180..c0682ad0d327 100644
--- a/math/py-bitvector/pkg-descr
+++ b/math/py-bitvector/pkg-descr
@@ -3,4 +3,4 @@ and for logical operations on such arrays. The core idea used in this Python
script for bin packing is based on an internet posting by Josiah Carlson to
the Pyrex mailing list.
-WWW: https://engineering.purdue.edu/kak/dist/BitVector-3.1.html
+WWW: https://engineering.purdue.edu/kak/dist/