aboutsummaryrefslogtreecommitdiff
path: root/math/py-bottleneck
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-09 19:05:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-09 19:05:19 +0000
commitcc8f398ebf8cf95c53ed05323f8724317d9eb3d2 (patch)
tree8329086162fdcdc0a8d2782f9a2f4fedc6e480a5 /math/py-bottleneck
parent7f779e65bf1982fec027870736cb896ce8fb28d6 (diff)
downloadports-cc8f398ebf8cf95c53ed05323f8724317d9eb3d2.tar.gz
ports-cc8f398ebf8cf95c53ed05323f8724317d9eb3d2.zip
Fix nosetests for non-default Python version
LOCALBASE/bin/nosetests is installed by py-nose of default Python version.
Notes
Notes: svn path=/head/; revision=498494
Diffstat (limited to 'math/py-bottleneck')
-rw-r--r--math/py-bottleneck/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/py-bottleneck/Makefile b/math/py-bottleneck/Makefile
index 60b49ab58993..2a79bfee9f9d 100644
--- a/math/py-bottleneck/Makefile
+++ b/math/py-bottleneck/Makefile
@@ -15,7 +15,7 @@ COMMENT= Collection of fast NumPy array functions written in Cython
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/bottleneck/LICENSE
-BUILD_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR}
@@ -36,6 +36,6 @@ post-install-DOCS-on:
cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
do-test:
- cd ${WRKSRC} && nosetests
+ cd ${WRKSRC} && nosetests-${PYTHON_VER}
.include <bsd.port.mk>