aboutsummaryrefslogtreecommitdiff
path: root/math/py-cdecimal
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2016-01-23 02:58:20 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2016-01-23 02:58:20 +0000
commitc34ae61a18a3bd0d841e28fb5cdce553ace0a81d (patch)
tree6845801fe665637f557edca033896493b0c3883e /math/py-cdecimal
parentdf4b8690b6684bcc6862d8306f0bc95a33050baf (diff)
Add py-cdecimal, a fast drop-in replacement for the Decimal module
in python < 3.3.
Notes
Notes: svn path=/head/; revision=406959
Diffstat (limited to 'math/py-cdecimal')
-rw-r--r--math/py-cdecimal/Makefile18
-rw-r--r--math/py-cdecimal/distinfo2
-rw-r--r--math/py-cdecimal/pkg-descr18
3 files changed, 38 insertions, 0 deletions
diff --git a/math/py-cdecimal/Makefile b/math/py-cdecimal/Makefile
new file mode 100644
index 000000000000..94c39814697a
--- /dev/null
+++ b/math/py-cdecimal/Makefile
@@ -0,0 +1,18 @@
+# Created by: Maksym Sobolyev <sobomax@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cdecimal
+PORTVERSION= 2.3
+CATEGORIES= math
+MASTER_SITES= http://www.bytereef.org/software/mpdecimal/releases/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Fast drop-in replacement for the Decimal module
+
+LICENSE= BSD2CLAUSE
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-cdecimal/distinfo b/math/py-cdecimal/distinfo
new file mode 100644
index 000000000000..c475c7c77524
--- /dev/null
+++ b/math/py-cdecimal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cdecimal-2.3.tar.gz) = d737cbe43ed1f6ad9874fb86c3db1e9bbe20c0c750868fde5be3f379ade83d8b
+SIZE (cdecimal-2.3.tar.gz) = 361809
diff --git a/math/py-cdecimal/pkg-descr b/math/py-cdecimal/pkg-descr
new file mode 100644
index 000000000000..a399745f69c2
--- /dev/null
+++ b/math/py-cdecimal/pkg-descr
@@ -0,0 +1,18 @@
+The cdecimal is a fast drop-in replacement for the decimal module in Python's
+standard library. Both modules provide complete implementations of the General
+Decimal Arithmetic Specification.
+
+Typical performance gains are between 30x for I/O heavy benchmarks and 80x for
+numerical programs. In a database benchmark, cdecimal exhibits a speedup of
+12x over decimal.py.
+
+ decimal cdecimal speedup
+pi 42.75s 0.58s 74x
+telco 172.19s 5.68s 30x
+psycopg 3.57s 0.29s 12x
+
+All Python versions from 2.5 up to 3.2 are supported. For the few remaining
+differences, read the cdecimal documentation. cdecimal has been included in
+Python-3.3.
+
+WWW: http://www.bytereef.org/mpdecimal/index.html