aboutsummaryrefslogtreecommitdiff
path: root/math/py-cma
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:19 +0000
commitbde795881fddbfdb05256917237ec01ffebd5bf4 (patch)
tree1245c41d8a6e6a4979df50ed6b0fc149c0d147ac /math/py-cma
parentb93cbf234246c7a852c0bfda1dc7cd8610519ada (diff)
downloadports-bde795881fddbfdb05256917237ec01ffebd5bf4.tar.gz
ports-bde795881fddbfdb05256917237ec01ffebd5bf4.zip
Add py-cma 2.6.0
pycma is a Python implementation of CMA-ES and a few related numerical optimization tools. The Covariance Matrix Adaptation Evolution Strategy (CMA-ES) is a stochastic derivative-free numerical optimization algorithm for difficult (non-convex, ill-conditioned, multi-modal, rugged, noisy) optimization problems in continuous search spaces. WWW: https://github.com/CMA-ES/pycma
Notes
Notes: svn path=/head/; revision=490585
Diffstat (limited to 'math/py-cma')
-rw-r--r--math/py-cma/Makefile23
-rw-r--r--math/py-cma/distinfo3
-rw-r--r--math/py-cma/pkg-descr9
3 files changed, 35 insertions, 0 deletions
diff --git a/math/py-cma/Makefile b/math/py-cma/Makefile
new file mode 100644
index 000000000000..97110eadd4f8
--- /dev/null
+++ b/math/py-cma/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cma
+PORTVERSION= 2.6.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CMA-ES for non-linear numerical optimization in Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0:math/py-numpy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-cma/distinfo b/math/py-cma/distinfo
new file mode 100644
index 000000000000..2b0e45441f18
--- /dev/null
+++ b/math/py-cma/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547723709
+SHA256 (cma-2.6.0.tar.gz) = ef9e21fd821485518341fe1b96be4d127f8b78e60aeb6a286d602dc98f25eab6
+SIZE (cma-2.6.0.tar.gz) = 213116
diff --git a/math/py-cma/pkg-descr b/math/py-cma/pkg-descr
new file mode 100644
index 000000000000..15f9f9e77b10
--- /dev/null
+++ b/math/py-cma/pkg-descr
@@ -0,0 +1,9 @@
+pycma is a Python implementation of CMA-ES and a few related numerical
+optimization tools.
+
+The Covariance Matrix Adaptation Evolution Strategy (CMA-ES) is a stochastic
+derivative-free numerical optimization algorithm for difficult (non-convex,
+ill-conditioned, multi-modal, rugged, noisy) optimization problems in continuous
+search spaces.
+
+WWW: https://github.com/CMA-ES/pycma