aboutsummaryrefslogtreecommitdiff
path: root/math/py-cryptominisat
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2018-06-17 20:36:22 +0000
committerGleb Popov <arrowd@FreeBSD.org>2018-06-17 20:36:22 +0000
commit2787ef7869a58363cc9249f3772f552c918228a3 (patch)
tree6e268ee1c150a85812b9cd04dd068b5794f2c85c /math/py-cryptominisat
parent1cbdeda5a7c33d5007551374d7e6c7d0da06a755 (diff)
Notes
Diffstat (limited to 'math/py-cryptominisat')
-rw-r--r--math/py-cryptominisat/Makefile20
-rw-r--r--math/py-cryptominisat/distinfo6
-rw-r--r--math/py-cryptominisat/files/patch-setup.py.in41
3 files changed, 31 insertions, 36 deletions
diff --git a/math/py-cryptominisat/Makefile b/math/py-cryptominisat/Makefile
index c23bb3b767fe..d4c9d6f98f7e 100644
--- a/math/py-cryptominisat/Makefile
+++ b/math/py-cryptominisat/Makefile
@@ -1,20 +1,21 @@
# $FreeBSD$
PORTNAME= cryptominisat
-PORTVERSION= 5.0.0
-PORTREVISION= 2
+DISTVERSION= 5.6.1
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= 6yearold@gmail.com
+MAINTAINER= arrowd@FreeBSD.org
COMMENT= Bindings to CryptoMiniSat (a SAT solver)
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE= MIT LGPL21
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21= ${WRKSRC}/../LICENSE.txt
+LICENSE_FILE_MIT= ${WRKSRC}/../LICENSE.txt
LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
-USES= compiler:c++11-lib python:-2.7
+USES= compiler:c++11-lib python
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
@@ -25,7 +26,12 @@ WRKSRC_SUBDIR= python
PYDISTUTILS_BUILDTARGET= build_ext --include-dirs=${LOCALBASE}/include
post-patch:
- ${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' ${WRKSRC}/setup.py.in
+ ${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' \
+ -e 's|$${CMAKE_C_COMPILER}|${CC}|' \
+ -e 's|$${CMAKE_CXX_COMPILER}|${CXX}|' \
+ -e 's|$${PY_C_CONFIG}||' \
+ -e 's|$${PY_LD_CONFIG}||' \
+ -e 's|$${APPLE}||' ${WRKSRC}/setup.py.in
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
post-install:
diff --git a/math/py-cryptominisat/distinfo b/math/py-cryptominisat/distinfo
index 91a4e803148a..fced09a5f3f6 100644
--- a/math/py-cryptominisat/distinfo
+++ b/math/py-cryptominisat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1469896511
-SHA256 (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 4c000daf9886e7c55f05b00247688ed0341a19cda13de49e2f35f40e95cc9910
-SIZE (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 596712
+TIMESTAMP = 1528628948
+SHA256 (msoos-cryptominisat-5.6.1_GH0.tar.gz) = f86c1cc94abcb9b9f9227fab2ea29f869b0b47f8dc83946e06e7d98b97cac2aa
+SIZE (msoos-cryptominisat-5.6.1_GH0.tar.gz) = 675234
diff --git a/math/py-cryptominisat/files/patch-setup.py.in b/math/py-cryptominisat/files/patch-setup.py.in
index a4aebe2d558c..8175e08ef02d 100644
--- a/math/py-cryptominisat/files/patch-setup.py.in
+++ b/math/py-cryptominisat/files/patch-setup.py.in
@@ -1,38 +1,27 @@
---- setup.py.in.orig 2016-07-06 12:22:54 UTC
+--- setup.py.in.orig 2018-06-05 06:06:54 UTC
+++ setup.py.in
-@@ -26,9 +26,9 @@ import sys
- from distutils.core import setup, Extension
- from distutils import sysconfig
+@@ -119,12 +119,12 @@ if platform.system() == 'Darwin':
--cconf = """${PY_C_CONFIG}""".split(" ")
--ldconf = """${PY_LD_CONFIG}""".split(" ")
--is_apple = """${APPLE}"""
-+cconf = """""".split(" ")
-+ldconf = """""".split(" ")
-+is_apple = """"""
-
- def cleanup(dat):
- ret = []
-@@ -81,12 +81,12 @@ __version__ = '@PROJECT_VERSION@'
-
- ext_kwds = dict(
+ modules = dict(
name = "pycryptosat",
-- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/pycryptosat.cpp"],
-+ sources = ["pycryptosat.cpp"],
- define_macros = [],
+- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/src/pycryptosat.cpp"],
++ sources = ["src/pycryptosat.cpp"],
+ define_macros = [('LIBRARY_VERSION', '"' + __LIBRARY_VERSION__ + '"')],
- extra_compile_args = cconf + ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat5-src'],
+ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src'],
- extra_link_args = ldconf,
+ extra_link_args = extra_link_args,
language = "c++",
- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib'],
+ library_dirs=['.', '/usr/local/lib'],
+ runtime_library_dirs=['${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}'],
libraries = ['cryptominisat5']
)
-
-@@ -111,5 +111,5 @@ setup(
- ext_modules = [Extension(**ext_kwds)],
- py_modules = ['pycryptosat'],
- description = "bindings to CryptoMiniSat (a SAT solver)",
+@@ -150,7 +150,7 @@ setup(
+ description = "Bindings to CryptoMiniSat {} (a SAT solver)".\
+ format(__LIBRARY_VERSION__),
+ # py_modules = ['pycryptosat'],
- long_description = open('${CMAKE_CURRENT_SOURCE_DIR}/README.rst').read(),
+ long_description = open('README.rst').read(),
- )
+ cmdclass={
+ 'test': TestCommand
+ }