aboutsummaryrefslogtreecommitdiff
path: root/math/py-cryptominisat
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2019-02-23 16:31:47 +0000
committerGleb Popov <arrowd@FreeBSD.org>2019-02-23 16:31:47 +0000
commita2f89c90f506f0f4e9114469afe75723f1a03136 (patch)
tree7ab2044cb20646faf64a9c00814eddcc545c6529 /math/py-cryptominisat
parent39e1603fe7dbc6636ba7b492d13fdff130d97f8e (diff)
downloadports-a2f89c90f506f0f4e9114469afe75723f1a03136.tar.gz
ports-a2f89c90f506f0f4e9114469afe75723f1a03136.zip
math/cryptominisat and math/py-cryptominisat to 5.6.8.
Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D19302
Notes
Notes: svn path=/head/; revision=493704
Diffstat (limited to 'math/py-cryptominisat')
-rw-r--r--math/py-cryptominisat/Makefile5
-rw-r--r--math/py-cryptominisat/distinfo6
-rw-r--r--math/py-cryptominisat/files/patch-setup.py.in14
3 files changed, 13 insertions, 12 deletions
diff --git a/math/py-cryptominisat/Makefile b/math/py-cryptominisat/Makefile
index fbce53c73219..e282df4104f5 100644
--- a/math/py-cryptominisat/Makefile
+++ b/math/py-cryptominisat/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cryptominisat
-DISTVERSION= 5.6.3
-PORTREVISION= 1
+DISTVERSION= 5.6.8
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -32,8 +31,10 @@ post-patch:
-e 's|$${CMAKE_CXX_COMPILER}|${CXX}|' \
-e 's|$${PY_C_CONFIG}||' \
-e 's|$${PY_LD_CONFIG}||' \
+ -e 's|$${CMS_FULL_VERSION}|${PORTVERSION}|' \
-e 's|$${APPLE}||' ${WRKSRC}/setup.py.in
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
+ ${CP} ${WRKSRC}/src/pycryptosat.cpp.in ${WRKSRC}/src/pycryptosat.cpp
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pycryptosat.so
diff --git a/math/py-cryptominisat/distinfo b/math/py-cryptominisat/distinfo
index 4de18bb7ff3b..08d9568c3c60 100644
--- a/math/py-cryptominisat/distinfo
+++ b/math/py-cryptominisat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1533812572
-SHA256 (msoos-cryptominisat-5.6.3_GH0.tar.gz) = c2fb4912cc8d8f3135af94581f11f30fd82347ee15ad8fb905e12a499e6fa87f
-SIZE (msoos-cryptominisat-5.6.3_GH0.tar.gz) = 683713
+TIMESTAMP = 1550905881
+SHA256 (msoos-cryptominisat-5.6.8_GH0.tar.gz) = 38add382c2257b702bdd4f1edf73544f29efc6e050516b6cacd2d81e35744b55
+SIZE (msoos-cryptominisat-5.6.8_GH0.tar.gz) = 701037
diff --git a/math/py-cryptominisat/files/patch-setup.py.in b/math/py-cryptominisat/files/patch-setup.py.in
index 8175e08ef02d..ad6f9c3d61bb 100644
--- a/math/py-cryptominisat/files/patch-setup.py.in
+++ b/math/py-cryptominisat/files/patch-setup.py.in
@@ -1,22 +1,22 @@
---- setup.py.in.orig 2018-06-05 06:06:54 UTC
+--- setup.py.in.orig 2019-02-19 20:49:20 UTC
+++ setup.py.in
-@@ -119,12 +119,12 @@ if platform.system() == 'Darwin':
+@@ -118,12 +118,12 @@ else:
modules = dict(
name = "pycryptosat",
-- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/src/pycryptosat.cpp"],
+- sources = ["${CMAKE_CURRENT_BINARY_DIR}/src/pycryptosat.cpp"],
+ sources = ["src/pycryptosat.cpp"],
define_macros = [('LIBRARY_VERSION', '"' + __LIBRARY_VERSION__ + '"')],
- extra_compile_args = cconf + ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat5-src'],
-+ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src'],
++ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src', '-xc++'],
extra_link_args = extra_link_args,
language = "c++",
-- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib'],
+- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib', '${PROJECT_BINARY_DIR}/lib/${CMAKE_BUILD_TYPE}'],
+ library_dirs=['.', '/usr/local/lib'],
runtime_library_dirs=['${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}'],
- libraries = ['cryptominisat5']
+ libraries = [libname]
)
-@@ -150,7 +150,7 @@ setup(
+@@ -152,7 +152,7 @@ setup(
description = "Bindings to CryptoMiniSat {} (a SAT solver)".\
format(__LIBRARY_VERSION__),
# py_modules = ['pycryptosat'],