aboutsummaryrefslogtreecommitdiff
path: root/math/py-cvxpy/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-18 23:04:41 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-18 23:04:41 +0000
commit7c1e2287ca4597d7431b0db32bf73f615edf77c1 (patch)
treeaaaf6c53dd082c9355188c513bce520ab08b21cc /math/py-cvxpy/Makefile
parent6c26a7393d1ab43e6262e46078db16e797a7c391 (diff)
downloadports-7c1e2287ca4597d7431b0db32bf73f615edf77c1.tar.gz
ports-7c1e2287ca4597d7431b0db32bf73f615edf77c1.zip
New port: math/py-cvxpy: Domain-specific language for modeling convex optimization problems
Notes
Notes: svn path=/head/; revision=485288
Diffstat (limited to 'math/py-cvxpy/Makefile')
-rw-r--r--math/py-cvxpy/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/py-cvxpy/Makefile b/math/py-cvxpy/Makefile
new file mode 100644
index 000000000000..1726b075fa5e
--- /dev/null
+++ b/math/py-cvxpy/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= cvxpy
+DISTVERSION= 1.0.10
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Domain-specific language for modeling convex optimization problems
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}ecos>=2:math/py-ecos@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fastcache>0:devel/py-fastcache@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}multiprocess>0:devel/py-multiprocess@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}osqp>0:math/py-osqp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.19:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scs>=1.1.3:math/py-scs@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toolz>0:devel/py-toolz@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>